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 Section 1: Setup and Installation of CAM-Duct  

 

1.1 Installing and Loading the CAM-Duct application for the first time 

 

Aim 

 

The user will gain the ability to install the Manufacturing software onto the PC by using the 

installation CD-ROM supplied by MAP. 

 

Details 

 

CAM-Duct CD-ROM – This contains the latest version of the software to be installed. Within the 

installation process, the HASP key drivers will be installed additionally and automatically. 

 

Step by Step 

 

� Close all running programs. 

� Load CD-ROM into drive and await auto-running menu. 

� Click “Install CAM-Duct” which is located as one of the right hand menu items. 

� Installation Wizard will now prepare for installation. Click Next. 

� Select the folder destination to where the CAM-Duct software is to be installed to by clicking 

Browse. Default: C:\CAM 

� Click Next to start installation. 

 

Areas Covered 

 

Install the Manufacturing software from CD-ROM. 

  

Completed q 
 

 

1.2 Editmap configuration 

 

1.2.1 Program Paths 

 

Aim 

 

You will be able to customize the program paths for the Manufacturing software if storing 

information on the network for backup purposes or require sharing databases between multiple 

users. 

 

Details 

 

ueditmap.exe – points to the various shared database folders and determines the structure of the 

manufacturing software installed. 
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Step by Step 

 

� Close all running programs. 

� Navigate to Windows Explorer and your Manufacturing installation folder default: C:\CAM. Or 

from your Start Menu find the following program. 

� Run the program ueditmap.exe “Editmap” from within the main installation folder or your 

Windows Start Menu. 

� Default location of the paths is locally – Please discuss with MAP representative before 

making changes. 

� Configure paths to where location of database is to be stored after these discussions and 

confirm your changes by selecting OK.  

 

Areas Covered 

 

Gain knowledge of the ueditmap external program.  

Manipulate each program path to the user’s preference. 

  

Completed q 
 

 

1.2.2 Setting up Global CAM Options. 

 

Aim 

 

You will be able to setup global Manufacturing options from the CAM/EST Options tab within 

ueditmap.  

 

Details 

 

The options listed below are available for customizing.  

Use Numpad: Allows the use of Numpad in takeoff views. This will appear on item entry if selected. 

Mainly used in Estimating 
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Select Full Rows in Job Contents: Allows for the user to select the full row rather than the item 

number when selecting items from within the Job Contents menu. 

 

Full Takeoff for Quick Takeoff Edit: If using Quick Takeoff and the user wishes to edit the item 

that has been accepted into the job already, the user can specify whether the view changes to Full 

Takeoff when the item is double clicked. 

 

Allow Editing of Catalogue Items: Allows the user to edit catalogue items which the dimensions 

or options have been previously set. This options if selected allows the user to customize the 

catalogue item. 

 

Show OpenGL 3D Viewer: Enables the use of the 3d viewer and enables the tab named 3d viewer 

from within Quick Takeoff view. This is associated with Trace Estimating which is an additional 

Dongle option and may not be enabled for some users. 

 

Custom Caption: Displays the caption entered here as your main window text. 

 

 
 

Support Email: The email address entered in here should read as above. This is the destination the 

support email would be sent to for your support attachments.  

 

Links Menu: You can customize the links from within the Help menu of the software. Adding in our 

MAP website is recommended as this would be saved from within the software Help menu under 

Helps > Links. This however is fully customizable. 

 

Step by Step 

 

� Select the ueditmap.exe program. 

� Click the CAM/EST Options tab. 

� Adjust settings as required but the recommended settings are as shown above. 

� Confirm your changes by selecting OK. 
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Areas Covered 

 

Customize global options within the Editmap interface.  

  

Completed q 
 

 

1.3 Utility Bar Customization 

 

Aim 

 

The ability to customize the Utility Bar to provide you with a manufacturing environment and display 

the most commonly used shortcuts. 

 

Details 

 

The Utility Bar is fully customizable for displaying most common shortcuts to other areas within the 

program. The default configuration is displayed below and is to provide the best possible 

environment for the Manufacturer.  

 

 
 

The utility bar can be customized by a number of ways. Simply right clicking on the utility bar will 

display the option ‘Customize’ and when selected, this will take you to the Utility Bar customization 

window. 

 

You can also access the customization window by navigating to File > Setup > User Interface and 

then selecting the Utility Bar Tab as shown below: 
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Show the Utility Bar: This option when selected will show the Utility Bar. If the user has closed the 

Utility Bar down previously and would like to display the bar again then selecting this option will 

display this on screen. When confirming the changes the bar will be displayed on screen for the user 

to then re-position to their preference. 

 

Use Large Icons: Large icons will be displayed on the Utility Bar. 

 

Display Text: Text will be displayed on the Utility Bar. 

 

Show Buttons: This area contains the shortcuts that are displayed on the Utility Bar. The left 

column lists the available options and the right column displays the icons currently in use. To move 

across any objects, select the option and use the arrow buttons left and right. You can then position 

in any order by selecting the option and then using the arrow buttons up and down. 

 

Step by Step 

 

� Navigate to File > Setup > User Interface and select the Utility Bar Tab. 

� Add in the Installed Machines option so it sits on the far left of the Utility Bar. 

� Confirm the change by selecting OK. 

 

Areas Covered 

 

Customization of the Utility Bar 

     

Completed q 
 

1.4 Custom Job Information Form 

 

Aim 

 

The user will gain the ability to be able to create/modify the custom job information form and enter 

custom job information data. 

 

Details 

 

There is the ability to create custom forms for entering job information on. There is a standard form 

available but you may want to create a personal customized version. The Job Information window is 

the start point when entering a new job into the program. The fields available for use are fully 

customizable and there are additional options that may be used. Please see a custom form example 

on the next page. 
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 Define Project Specifications – This option allows you to determine which specifications are 

to be used within the Job. You can restrict specifications by adding into the allow list the 

specifications that are only to be used. 

 

 Takeoff – This option records the custom information entered on the form creates the job. 

 

 Estimate Summary – This options would allow you to view the Estimate Summary from the 

job if Estimating is enabled on your Dongle. 

 

 Variations – This option allows for you to record variations and provides you with dates and 

times for when changes had been made to the job. 

 

 Print Reports – The Print Reports option allows quick access to the Print Preview section of 

your selected reports. Reports can be printed relating to the job from this option. 

 

The fields that are displayed on the custom Job Information form can be user defined via the User 

Interface > Interface Options > Job Information Form > Use Custom Form > Edit button. 
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This will open the design view of the form ready for the user to customize the displayed fields. The 

user can simply drag and drop the required fields onto the left pane canvas from the available fields 

list on the right hand pane. 

 

Right Clicking and selecting Properties on the objects, within the form, allows the user to further 

customise the layout and information displayed. 

 

 
 

You can additionally change the background of the form if desired. Right clicking on the design 

layout pane will allow for this ‘Background Properties’. 
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.  

 

 Test Form – Allows you to display the form after editing. This allows you to verify the field 

positioning and layout is ok. 

 

 Edit Layout – This is the above view and is where the customized fields can be edited. 

 

 Define Tab Order – Allows for you to define the order of the tab and the cycle of fields it 

would move to when pressed. 

 

Step by Step 

 

� Create a custom Job Information Form within User interface. 

� Within the Job Status Fields tab create a status field that will move the job to a folder when 

activated. 
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� Confirm your changes by selecting OK 

� Navigate to the Interface Options tab. 

� Click the Edit button next to Use Custom Form when this option is selected. 

� Customize the Custom Form by adding in Job Status Fields from the right hand pane. 

� Test the design of the status to make sure the layout is ok by clicking the test icon to switch 

between modes. 

� Create a new job and ensure the status option is displayed on the Job Information form. 

 

Areas Covered 

 

Editing the Custom Information Form and apply additional fields 

Creation of Job Status fields and how they can apply to your job. 

     

Completed q 
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Section 2: Job Browser 

 

2.1 Job Browser Views Explained 

 

Aim 

 

The user should gain the ability to use the Job Browser efficiently and be able to navigate and use 

all the views available. 

 

Details 

 

The Job Browser is recommended to be the start point when first running the Manufacturing 

software. You can set this to show every time the program starts. It is used to navigate around the 

job project structure and is a tool where you can open previous jobs and also create new projects or 

folders. 

 

 Goto Parent Folder: Can be used to move to a higher level folder within the structure. 

 

 Create New Project Folder: Create a new folder as a subfolder to the selected folder 

 

 Delete Selected Folder: Deletes the selected folder. 

 

 Rename Selected Folder: Renames the selected folder. 

 

 Edit Project Information: You can edit the folders properties and apply or restrict 

specifications to all items within that Project folder. 

 

 New Job: The icon New Job (*.MAJ) will create a new job but if changes were to be made to 

the database, this will be changed globally and affect all. 

 

 New Archived Job: For estimating – an Archived job (*.ESJ) should be used to create all your 

new jobs. This will store all the relevant database settings and costs into one controlled file.  

 

The Archived Job will take a copy of the current database and all changes made to the database will 

be stored within this file. This allows changes to be made that are only specific to that job and will 

not affect the global settings from the database. 
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 Purge Jobs: Attempts to delete the job and all files associated with it (NC, Remnants, etc). 

 

 Job Information: Displays the Job information form for the highlighted job. 

 

 Duplicate Job: Duplicates the selected/highlighted job 

 

 Views: Different views that are available for displaying on screen. We 

recommend using the Details view which can be tailored to display fields relevant to you. 

 

 Customize: Allows you to add/change fields that are displayed in the Browser window. 

 

 Job Types:  Enables you to sort between job types, whether it be a Job 

(*.MAJ) file or an Archived Job (*.ESJ) file type. The drop down list when selected would apply the 

filter. 

 

Step by Step 

 

� Open the Job Browser Window from File > Browse for Jobs or alternatively your Utility Bar 

shortcut. 

� Create a new Project Folder and create a sample Job. 

� Fill out the Job Information entries giving it a name of ‘Example1’. 

� Select the Takeoff button. 

� Insert an item into the job, Nest and write NC. 

� Enter on the Job Information that the status is now completed, then close the job down. 

� Open the Job Browser Window and locate the job created in its Project Folder. 

� Customize the view so that Details are showing. 

� Add into the view Job Status Fields #1 

� Rename the header via the Properties. Name it ‘Completed’. 

� Click OK to confirm the changes etc. 

� You should now have a completed field with the date displaying for when the job was 

completed. 

 

 
 

Areas Covered 

Job Browser customization of views 

Different Job types (Archive and Manufacturing). 

     

Completed q 
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Section 3: Item Folders 

 

3.1 Customizing your Item Folders view 

 

Aim 

 

The ability to customize the views within Item Folders and enable us to visualize Cut Types, Pattern 

Groups, CID Numbers, Catalogue Flags etc . 

 

Details 

 

All patterns are stored within folders. Folders are used to categorize patterns into Job related 

criteria. This also allows quick access to the patterns within these libraries. 

 

 
 

The folder structure allows for patterns to be organised into groups. As a default, the patterns are 

divided by their general form: oval, rectangular, round etc. The folder structure is totally 

customizable - folders can be created, removed and their contents modified. The default folder 

structure for the Manufacturing software is illustrated above. 
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We can also edit the default views of the item folders to display more relevant information, such as 

the CID number attached to each item and also the Cut Type, Pattern Group etc. 

 

 
 

Right Clicking and then selecting Customize on the column headers or navigating to the View > 

Customize menu will allow for the customization of the fields. You can select from the available list 

on the left pane, which fields are to be displayed, by highlighting the option and selecting the left or 

right arrows to move across the item. 

 

You can customize each of the folders views individually.  

 

Step by Step 

 

� Click on the Item Folders shortcut from the Utility Bar or navigate to Utilities > Item 

Folders 

� Customize the details view by adding in the following fields for a “Bought Out” folder. 
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� Confirm the changes for this folder. 

� Locate a folder that contains your manufactured items. This time insert an additional field 

called Item Service Type in the right hand pane.  

� Then confirm the changes by clicking OK. 

� You should now notice that one folder contains additional information on Services that are 

assigned. 

 

Areas Covered 

 

Editing views to individual folders to display additional Item Information 

     

Completed q 
 

 

3.2 Creating / Modifying Item Folders 

 

Aim 

 

The ability to create/modify Item folders and their contents. 

 

Details 

 

The Item Folders are customizable for users wanting to create their own structure or libraries. 
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Right Clicking on a Folder will bring up a dialogue box to allow the creation of a New Folder. 

 

 
 

Selecting New Folder then brings up a Page Properties window for the user to provide a Name, 

Type for their folder and also a Path to where it will be stored. This could be a network location if 

desired dependant on whether the items are to be shared.  

 

The Add Sub Folders Too option will also include all sub directories. Selecting Browse enables the 

user to browse to the desired folder location. 

 

Items can be copied from one folder to the other if duplication is required. There maybe an occasion 

when locked dimensions are required on items if most dimensions other than width, depth and 

length were kept consistent. You can achieve this by editing the default item settings. 

 

Step by Step 

 

� Click on the root of your Item Folders structure. 

� Right click and select New Folder 

� Give your folder a name and then path to a location you want to save the items to. 

� Copy and paste a Taper item from the Rectangular library into your new folder. 

� Lock dimensions by selecting the item and then clicking Edit. 

� On the Dimensions tab for the part, select the pad locks so they appear closed for the 

following dimensions. 
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� The unlocked padlock above symbolizes the values that are available for changing when 

entering the item into your job see below. 

 

 
 

Areas Covered 

 

Creating New Item Folders 

Editing and copying existing items 

Applying locked Dimensions 

     

Completed q 
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Section 4: Main Database  

4.1 Configuration Setup 

 

Aim 

 

To allow the user to create an automatic backup procedure and also setup the units of measurement 

within the software. 

 

Details 

 

The Configuration tab allows the user to set switches that determine how the program will function. 

The main areas of this section would be the units to use when inputting dimensions etc, how precise 

the dimensions are in takeoff views and how frequent your jobs are backed up. 

 

 
 

Step by Step 

 

� Navigate to the Configuration section of the Main Database. 

� Ensure ‘Automatically Backup the Job at Key Points +’ <Value> is selected and contains 

a value greater than one for the number of Items Added. 

� Confirm the changes by selecting OK. 

 

Areas Covered 

 

Creation of Automatic Backup Procedure 

Units of Measure 

     

Completed q 
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4.2 Currency 

 

Aim 

 

Define the currencies to be used within the software. 

 

Details 

 

Here you can set the default currency that the program will use if costing, and also add additional 

currencies by providing the latest exchange rate figures. These currencies maybe used for displaying 

material costs in reports. 

 

 
 

The exchange rates entered will need regular updates as there is no automatic procedure for 

accessing current rates of exchange. 

 

Step by Step 

 

� Navigate to the Currency section of the Main Database. 

� Define the currencies required from end reports etc. 

� Apply the current exchange rates to these. 

� Confirm changes by selecting OK. 

 

Areas Covered 

 

Configure Currencies and Exchange Rates. 

 

Completed q 
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4.3 Customizing your Materials 

 

Aim 

 

The ability to setup new materials, thicknesses and assign costs to specific material 

 

Details 

 

The Material section allows the user to set up specific materials and different thicknesses, along with 

details of cost’s and weight for each of these. 

 

 
 

 Print Material(s): Creates a report on all your materials which details the cost/weight 

assigned to each one. The option to print the highlighted material or all materials in your database 

is prompted when the icon is selected. 

 

 Material: When the drop down is selected, this list displays the 

current materials in your database. Selecting the material will display all Gauges’ in the list 

underneath. 

 

 Properties: Displays the properties dialogue box to enable changes to that specific material. 

See Material Properties below: 
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The user can create the Material name and assign to a Group if desired. The abbreviation can be 

used on reports and the Density if known can be used to calculate the weight. 

 

 Add New Material to Database Now: Provides you with the option to add a material type to 

the database. 

 

 
 

The software allows you to copy the existing material setup over to the newly created material type 

if the values are to be kept similar. This saves the user having to re-create from scratch. 

 

 
 

You can additionally copy any specification entries over with your material. The existing specification 

will be applied to the new material if selecting yes to the above option. 

 

 
 

 Delete Material: Allows you to delete the selected material from your database. 

 

 New Gauge: The new icon at the left provides the user to create a new thickness for the 

selected material. See below: 
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The user can enter the Thickness, Wire Gauge, and the Cost per kg. The Weight in kg/sq m does not 

need to be entered if the Density of the material was entered earlier, if the Density was not entered 

then the weight, in Kg’s, for a square metre of material must be entered. 

 

 
 

Sizes: You can setup numerous alternate sizes for specific thicknesses of material if required.  

 

The   icon indicates that this is the default sheet size for that selected material thickness. 

 

Areas Covered 

 

Material Setup 

The Applied Material Costs 

Default Sheet Sizes 

 

Completed q 
 

 

4.4 Notes 

 

Aim 

 

To set up pre-defined Notes into the Notes table. 

 

Details 
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Lines of text, to be used as notes, can be entered in the notes table. Later these notes can be 

assigned to items as they are accepted into jobs. 

 

 
 

Step by Step 

 
Click on the Green New Icon to create a new Note 

Type in “Extract Only” 

Click on “Apply” and “Ok” to accept the settings. 

Select an Item from Item Folders and apply the new Note to the Item in takeoff. 

 

Areas Covered 

 

Creating a new Note 

Applying the Note during Take-off. 

 

Completed q 
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4.5 OpenGL Options 

 
Aim 

 
To assist in viewing the Items in take-off, this will give dimension lines and proper shading to the 

part. 

 

Details 

 

OpenGL will give dimension lines and proper shading to an item in Takeoff. To activate this go to 

File > Setup > Main Database > OpenGL Options, or click on the Main Database icon, in the 

Utility Bar. 

 

 
 

The options available are as follows. 

 

Enable OpenGL 

This tick box turns on or off the OpenGL functionality.  To use OpenGL you must have an OpenGL 

compliant Graphics Card and it is recommended you have the latest drivers from your card 

manufacturer.  This box will not be enabled if you have a pattern open for editing or if there are 

already items put into a job. 

 

Lighting options: Enable dynamic lighting 

This toggles on or off the dynamic lighting effect, without dynamic lighting the new dimension lines 

will be shown but there will be no shading on the pattern as it uses a "flat" lighting effect. There are 

3 sliders that affect the lighting, these are: 

 

Ambient light 

This controls the main light source and affects the amount of light reflecting onto the pattern. If it is 

imagined that the pattern is in a square room with a single light source, the ambient light is the 
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amount of light, reflected off the walls, back onto the pattern. Moving the slider to the left reduces 

the light reflecting onto the pattern. 

 

Light intensity 

This controls the brightness of the light source.  The further to the left the slider is moved the 

darker the light becomes. 

 

Light 

This controls the distance of the light source to the pattern. the further to the left the slider is 

moved the closer to the pattern it becomes, moving it all the way to the left will put the light source 

into the middle of the pattern. 

 

By manipulating these 3 sliders you can adjust the lighting to the settings that you want. 

 

 

 
 

Dimensioning options: Arrows 

There are 4 different Arrow sizes available to use. These are None, Small, Medium, and Large. 

 

Dimensioning options: Margin 

This slider determines the amount of space between the pattern and the edge of the window.  The 

further to the left the slider is moved the smaller this margin becomes. 

 

Dimensioning options: Dimension offset 

This slider determines the distance away from the pattern the dimension lines are placed. The 

further to the left the slider is moved the closer to the pattern edge the dimension lines are placed. 

 

Dimensioning options: Stencil Buffer 

This option is needed by OpenGL to display the dimensions correctly. Some cards may have 

problems with this and so it can then be turned off. 
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Dimensioning options: Font 

This allows the user to choose the font displayed used for the dimension measurements. Fonts are 

selected from the fonts installed in your Windows/Fonts directory. 

 

Printing options: Line thickness 

This determines the thickness of the line shown when printing the pattern.  The further to the left 

the slider is moved the thinner the line becomes. 

 

Printing options: Darker/Lighter 

This determines how dark the picture will be when printing the pattern. The further to the left the 

slider is moved the darker the image becomes. 

 

Use Software Rendering 

This will use system memory instead of the Chip memory based on your Graphic Card, can resolve 

some issues with inbuilt Graphics Cards. 

 

Hide dimensions below tolerance 

This enables the user to determine below what size not to report the dimension, this is useful in 

some patterns where you may wish to eliminate some of the information displayed so that it 

becomes less cluttered.  The options available are: 

 

Angle 

When ticked the display will not show any dimension lines for an angle below the dimension 

specified.. 

 

Radius 

When ticked the display will not show any dimension lines for a radius below the dimension 

specified. 

 

Other 

When ticked the display will not show any dimension lines for any line below the dimension 

specified. 

 

The Advanced Button  

This contains the advanced options for OpenGL, which are detailed below. Click on this button to 

bring up the OpenGL Advanced options. 
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Use Overlays 

The overlay is used by the system to speed up large drawings when zooming or panning. 

 

Rendering 

The options here are advanced users to alter performance and graphical reproduction techniques 

with in the software. These settings should only be changed under the instruction of your supplier 

 

Debug Information 

The options here should be left unselected unless specifically requested by your supplier.  These 

generate log files that can be used to debug graphical errors. 

 

Areas Covered 

 

Setting the type of graphical interface in Takeoff and optomising the OpenGL Options 

 

 

Completed q 
 

 

4.6 Oversize Check 

 

Aim 

 

To check items and parts in a job against default sheet sizes and sheets in stock and determine how 

the oversized part is fitted. 

 

Details 

 

The Oversize Check dialogue enables the user to configure CAM-Duct to check parts in a job against 

default sheet sizes and sheets in stock and determine how the oversized part is fitted. To access the 

Database Editor, click on File > Setup > Main Database > Oversize Check or select the Main 

Database icon from the Utility Bar.  
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Check for Oversize at Take-Off / Check for Oversize before Nesting 

With either of these options checked, the pattern at takeoff and / or prior to nesting is checked 

against the sheet sizes set up in Materials.  

 

Preferred Part Split at: either Maximum Sheet Size - this option splits the pattern development 

so that the largest possible size can be placed onto the sheet or Equal Part Sizes - this option 

splits the pattern development into two or more equally-sized developments. 

 

Minimum Part Size: the value will set a minimum size for the development when the option 

Maximum Sheet Size is enabled. This value will then limit the size of the split that the program will 

create when automatically nesting. 

 

Duct Tab 

Rectangular 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams database. Select a seam which will be used for all oversized rectangular patterns. 

When selecting a rectangular oversized pattern at takeoff the Oversized Item dialogue box will 

appear, displaying the seam selected here as the default option for Use Oversize Seam. 

 

Circular 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized circular patterns. When 

selecting a circular oversized pattern at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

Flat Oval 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized flat oval patterns. 

When selecting a flat oval oversized pattern at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

Standard 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized standard parts. When 
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selecting a standard oversized part at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

Square To Round 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized square to round 

patterns. When selecting a square to round oversized pattern at takeoff the Oversized Item dialogue 

box will appear, displaying the seam selected here as the default option for Use Oversize Seam. 

 

  

 

Insulation Tab: 

Rectangular 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams database. Select a seam which will be used for all oversized rectangular patterns. 

When selecting a rectangular oversized pattern at takeoff the Oversized Item dialogue box will 

appear, displaying the seam selected here as the default option for Use Oversize Seam. 

 

Circular 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized circular patterns. When 

selecting a circular oversized pattern at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

 

 

 

Flat Oval 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized flat oval patterns. 

When selecting a flat oval oversized pattern at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

Standard 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized standard parts. When 

selecting a standard oversized part at takeoff the Oversized Item dialogue box will appear, 

displaying the seam selected here as the default option for Use Oversize Seam. 

 

Square To Round 

Clicking the down arrow at the end of the field will display all of the available seams from the 

Oversize Seams Database. Select a seam which will be used for all oversized square to round 

patterns. When selecting a square to round oversized pattern at takeoff the Oversized Item dialogue 

box will appear, displaying the seam selected here as the default option for Use Oversize Seam. 

 

Automatically use these settings without prompting 

This tick box allows the Oversized Item dialogue box to be bypassed and the part to be split to the 

default settings established here on every occasion. If the pattern's size is larger than the values set 

in the database and the Automatically use these settings without prompting box wasn't ticked, then 

the following dialogue box is displayed at acceptance, warning the user that the pattern accepted is 

oversized. 
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The options as defined earlier for Preferred Part Split and Minimum Part Size are displayed, but 

they can be altered for this particular part. 

 

Use Oversize Seam 

This will display the relevant seam as defined in the database editor, taking account of the library 

that the part in question is taken from. 

 

Step by Step 

 

• Go to Item Folders and select a Rectangular Square Bend 

• Enter dimensions of 1600 square 

• Accept the Item into the Job 

• Change the default Oversize split to Equal Part Sizes. 

• Apply to All 

• Confirm the Item has been Split by Editing the Developments in the Job Contents Screen. 

 

Areas Covered 

Handling of Oversized parts 

Completed q 
 

 

4.7 General Nesting 

 

Aim 

 

Configure and setup the general nesting parameters for Manual and Automatic nesting. 

 

Details 

 

The general nesting dialogue configures settings for both automatic and manual nesting. Click on 

File > Setup > Main Database > General Nesting or select the Main Database icon from the 

Utility Bar.  
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Minimum margin between nested parts: 

This value sets a surrounding border around all nested parts. If a value of 10mm is given, all parts 

will be at least 10mm apart. The margin is not cumulative between two parts, it merely specifies a 

minimum distance. This distance also applies from the part to the sheet edge. 

 

Additional Sheet Edge Margin 

This value adds on any extra required margin around the periphery of the sheet. The value is 

subtracted from all sides and the effect of this in conjunction with the minimum margin is 

cumulative. Therefore a value of 10mm here with a minimum margin of 10mm will result in a 20mm 

border around the edge of the sheet. 

 

Ignore Lead-ins less than: 

The value entered here allows lead-ins up to a certain value to encroach into the minimum margin. 

It therefore makes sense to set this value to be less than the minimum margin. If the lead is larger 

than this value, the whole part is moved to preserve the minimum margin. 

 

New Sheet 

This setting determines how automatic nesting will react when a new sheet is required for the job. 

 

 

Use default sheet size 

This will use the sheet with the green tick next to it in Materials.  

 

Allow Alternate Sizes to Avoid Oversizing 

This gives the option to prompt for new sheet sizes if the parts are oversized. 

 

Use Stock Sheets from Sheet Management 

This is available if the sheet management option is enabled. It can be used to fill remnant sheets if 

they are saved as remnants. The cut off figure for usability is expressed as a percentage of the 

sheet area, and is input here. 

 

Prompt for new sheet sizes 
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This will display a dialogue box every time the Automatic Nesting module requires a new sheet to 

continue. Standard sheet sizes can be selected from a drop down menu or a remnant size can be 

directly entered. 

 

Re-order Nest Automatically 

This switch allows users with only one machine (or similar machines) to re-order the nest every time 

the NC is written. This is useful when jobs are Auto-Nested, then manually nested. This option saves 

the user having to remember to click on Select Machine in Manual Nest before the NC is written 

again. 

 

Step by Step 

 

• Change the New Sheet settings to “Prompt for new sheet sizes” 

• Nest, using Automatic Nesting to bring up the Nesting Prompts. 

• Delete the Nest and change the Nesting Options back to Use default sheet sizes. 

• Use Automatic Nesting to see the difference. 

 

Areas Covered 

Changing the nesting parameters 

 

 

Completed q 
 

 

 

4.8 Autonest Options 

 
Aim 

 

Configure and setup the Autonest parameters for Automatic nesting. 

 

Details 

 

The Autonest Options dialogue enables the user to set the accuracy and method of Autonesting. The 

settings here will indirectly determine the amount of sheet wastage as the accuracy and speed of 

the nesting exist in a trade-off relationship. 

 

Click File > Setup > Main Database > Autonest Options or select the Main Database icon 

from the Utility Bar. 
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The slider bar weights the nesting procedure between accuracy on the left and speed on the right. 

The positioning of this bar is therefore a guide to the efficiency of the whole procedure. An Accurate 

setting will give a tight nest with the absolute minimum wastage considering processor speed. The 

Faster setting will give a less efficient nest but will complete the nesting procedure quicker. The 

Optimal setting is a balanced trade-of between the two extremes. If the nesting at this setting is not 

deemed accurate enough, the slider can be positioned to the left. Alternatively, if the procedure is 

not considered fast enough, the slider can be moved to the right. 

 

Options 

 

Use Existing Sheets In Job 

This option will use any empty "Untitled" sheets that already exist in the job, as long as the material 

and gauge correspond to the items being nested. 

 

Try Alternative Solutions if Target not Reached 

This option gives the auto nest function the opportunity to try several nesting combinations in order 

to achieve the best possible nest. 

 

Optimisations 

 

Rotate Parts to Minimum Rectangles 

Rotating parts to minimum rectangles allows for some shapes to be squared off to the edge of the 

sheet. This is obviously an advantage on a rectangular sheet. 

 

Pre-Nest Parts with Each Other 

Pre-Nesting will attempt to create a rectangle from the parts on the sheet and then nest these 

rectangles as entities themselves. 

 

Pre-Nest One-off Part Qties 

This will try to nest one off parts together, if this produces satisfactory results the pre-nest will be 

kept. 
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Pre-Nest Parts in Holes 

Pre-Nesting in holes allows the procedure to place parts inside other parts and will keep the 

combination together if the nesting appears to provide sheet economy. 

 

Allow Nest In Stitched Holes 

This allows parts to nest inside the stitched holes of larger parts. 

 

Allow edge nest parts equal to sheet width 

This option allow parts that are equal to the sheet width to be cut, where normally the part would be 

oversized. The edge of the sheet will then become the edge of the nested part. 

This is particularly useful for cutting straight duct that is equal to the sheet width, when a de-coiler 

is not available. 

 

Areas Covered 

 

The optimising of the Autonesting routines to eliminate sheet waste. 

 

Completed q 
 

 

4.9 Item Entry 

 

Aim 

 

Customise the Carry Over information and Specifications called for during takeoff and Item Entry. 

 

Details 

 

The Carry Over options allow the user to set what information is to be carried over from one entered 

Item to the next.  This can be particularly usefull when inputting Items from a drawing when the 

extra information on one part is likely to be the same on the adjoining part.  The options available 

are listed below.   
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Auto-Increment Item Numbers 

Advances the item number of a part or pattern by one each time it is accepted into a job. The item 

number is located on the Item tab in pattern takeoff. If this is not ticked, the default is to put the 

name of the part in the item number field 

 

Carry Over Notes 

If ticked, applies the notes selected for the previous part to the current part. 

 

Carry Over Insulation 

If ticked, applies the insulation selected for the previous part to the current part. 

 

Carry Over Duct Facing 

If ticked, applies the duct facing selected for the previous part to the current part 

 

Carry Over Order Number 

If an order number has been added to the item tab of takeoff using the Takeoff > Customise menu, 

it will be automatically assigned to the last entered value. 

 

Carry Over Pallet Number 

Automatically assigns the same pallet number to consecutive parts until manually changed by the 

user. Pallet number is located on the item tab on pattern takeoff if takeoff has been customised 

using the Takeoff > Customise menu (this option is detailed in the Centre Line Input topic) 

 

Auto-Increment Pallet Number 

Advances the pallet number by one for every part accepted through takeoff. 

 

Carry Over Section Type 

If ticked, the section that the last part was entered into will apply to the next part to be entered. 

 

Carry Over Item Page Number 

Item page number can be used to match items to an external document. This feature is primarily 

designed for estimating jobs where a quantity surveyor's report is being used to enter the job. 

 

Carry over Service 

If Service information is applied to the items in the job the Service details are carried over to the 

next item. 

 

Carry over Status 

Item status is normally used in conjuction with Barcoding.  This information can then be carried over 

from item to item as they are input into the Job. 

 

Carry Over Double Wall 

If Double Wall has been added to the item tab of takeoff using the Takeoff > Customise menu, 

the Double Wall settings of the previous part will be carried over to the current part. 

 

Current Values 

Allows the default item number, material and gauge to be changed. 

 

Current Specs 

Sets the specification to be used for Rectangular, Circular, Flat Oval. and Standard Parts 

respectively. 

 

Multiple Item Properties 

This option allows the user to set which fields can be changed when viewing the properties of more 

than one item at a time. 

 

Click on the Multiple Item Properties button and the following dialogue box will appear. 
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The right hand pane displays all of the fields currently in use when changing the properties for 

multiple items. The left hand pane displays all of the fields that may be used. 

 

To add items to the right hand pane, first select the relevant field in the left hand pane and click the 

right pointing arrow. The field will then appear in the right hand pane. 

 

To remove items from the right hand pane, select the relevant field in the right hand pane and click 

on the left pointing arrow. 

 

Areas Covered 

 

Carry Over options 

Multiple item properties 

 

Completed q 
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 Section 5: Pattern Database  

 

5.1 Seams 

 
Aim 

 

To define the various types and allowances associated with Seams used in Ductwork. 

 

Details 

 

There is no limit to the number of seams that can be defined. Click on File > Setup > Pattern 

Database and select the Seams tab or select the Pattern Database icon from the Utility Bar. 

 

 

 
 

To amend details, double-click on the relevant seam name. To create a new seam right-click under 

the listed seams and choose New or click the   icon. In either case, you will be presented with a 

dialogue box similar to the following one. 

 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 39 of 166 

 

 
 

The following can be defined for each seam: 

 

Name 

Enter the name which describes the seam. Try to keep the name as short as possible since some 

dialogue boxes only display a limited number of characters - e.g. PITTS-S for Small Pittsburgh. 

 

Male Allow 

This value defines the male allowance which will be added to the male developments of any fitting 

using this seam - e.g. the cheeks or sides of a Square Elbow. 

 

Female Allow 

This value defines the female allowance which is added to the female developments of any fitting 

using this seam - e.g. the heel and throat wrappers of a Square Elbow. 

 

Folds 

The folds allowance is used to adjust the calculated length of heel and throat wrappers. This 

compensates for the number of material folds in the female part of the seam. 

 

Vee Depth Male / Vee Depth Female 

This is the depth of the V-notch used in developments. 

 

Male Roller Allowance / Female Roller Allowance 

The seam may need to be notched back greater than the seam allowance to allow clearance for 

machine rollers, and this defines the allowance required for that clearance. 

 

Areas Covered 

Creation and setting up of Seam Allowances. 

 

 

Completed q 
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5.2 Connectors 

 

Aim 

 

The ability to assign the parameters necessary to create the connector and apply the correct 

ancillary materials to connectors.   

 

Details 

 

The manufacturing details for connectors are configured in the File > Setup > Pattern Database > 

Connectors section of the database. 

 

 
 

Name: This is the name you will use to identify the connector when applying it to an Item or 

Specification. 

 

Turnover: This value defines the extra metal allowance required to form the connector. This value 

can also be a negative number and will always be added or subtracted to the duct development. 

 

Straight: This value defines the amount of straight length. This is not usually added to the duct, 

but may be if the length of straight at the duct end that this connector is applied to is not long 

enough to accommodate the connector. 

 

Straight Notch: This is the notch used to remove Connector - Seam intersections. 

 

Sloping Notch: This is the notch used in situations such as transitions and drop cheeks. Its primary 

usage is to remove taper extensions. 

 

Type: The pull down menu lists the different types of connector setting, details of which are listed 

below. 

 

• Whole  

One connector per duct end.  

• Shared  

One connector for every two duct ends assigned.  

• S & D Auto  

The "C" drive cleat will automatically be assigned to the longest of the two sides, either the 

width or depth. This type is shared.  
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• D & S Auto  

The "S" cleat will automatically be assigned to the longest of the two sides, either width or 

depth. This type is shared.  

• S & D Manual  

The "C" drive cleat will always be assigned to the width. This type is shared.  

• D & S Manual  

The "S" cleat will always be assigned to the width. This type is shared. 

 

Adjust Long / Side / Adjust Short / Drive: 

These values are added or subtracted from the length of the connectors when lengths are shown on 

reports. 

 

 

Profile: This determines whether the connector is an external (Yes) or self flange (No). 

 

Slits: Values "Yes" or "No" determine whether or not Slits are included in the connector.  The slits 

are defined in the Pattern Options Database and are used in Self Flanges that require Corners. 

 

Fold Slit: Values of "Yes" or "No" determine as to whether fold slits are included in the 

development.  

 

Fold Slit Gap: The distance from the top of the connector that the slit will start. A value of 0.0 will 

cut the slit from the top edge. 

 

Fold Slit Body Gap: The distance from the Straight allowance that the slit will terminate. A value of 

0.0 will cut the slit the full Turnover allowance. 

 

Override Tie Rod Offset Width: There are 3 settings that can be used. 

"Not Used" will ignore this setting and offset the Tie Rod according to the Tie Rod settings in 

Stiffeners. 

"Off" will override the settings in the Tie Rod settings and remove any tie rods from the connector 

end. 

"Value" will allow you to override the offset in the Tie Rod Settings and apply the new value when 

this connector is used. 

 

Override Tie Rod Offset Depth: These setting are the same as the Override Tie Rod Offset Width 

with the exception that they are applied to the items Depth. 

 

Override Insulation Adjust: There are 2 settings that can be used. 

"Not Used" Will ignore this setting and apply the insulation adjustment determined in the Pattern 

Database > Pattern Options > Insulation Database. 

"Value" will allow you to override the settings applied in the insulation adjustment determined in 

the Pattern Database > Pattern Options > Insulation Database 

 

Seam Cut Back (Male): A value here will cut remove the seam from the Male side, using the 

specified value from the connector end, this will be in addition to any seam removal applied in the 

Connector notching. 

 

Seam Cut Back (Female): A value here will cut remove the seam from the Female side, using the 

specified value from the connector end, this will be in addition to any seam removal applied in the 

Connector notching. 

 

 

Connectors required for use can also have costing properties we can define. 

 

The Estimating icon  within the File > Setup> Pattern Database > Connectors section 

provides the area for where we can set this up. 
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The estimating section, to the connector’s, details by group all the connectors currently listed in the 

database. 

 

Double click the name of a connector that needs costing values adding to it.  The Estimating 

options will be now displayed. 
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The Name will be the same as the one entered in the manufacturing details. 

 

Material (Slip): This is the name of the material actually used for forming the connector. Click on 

the drop-down menu to view a list of materials that have already been set up in the Ancillary 

Materials section of the Ancillaries tab within the Pattern Database. Select the required 

material. 

 

Drive Material: If Whole or Shared have been selected in the Type option in the manufacturing 

properties of a connector, leave this section as None.  If any of the other four Slip and Drive options 

S & D Auto, D & S Auto, S & D Manual D & S Manual are selected this will only apply material to 

Drive side. 

 

Corners: This field is used to select the type and price of corner needed to produce a flange. These 

should be set up in the Corners section of the Ancillaries tab in the Pattern Database. 

 

Bolts: This field is used to select the type and price of Bolts needed to produce a connector. These 

should be set up in the Fixings section of the Ancillaries tab in the Pattern Database. 

 

Qty: Specifies a set quantity of Bolts required for a single connector. 

 

+ per (m): Specifies the number of Bolts required per meter. The number of Bolts is calculated 

individually for each of the four adjusted profiles. The totals are then added together. 

If a value is entered in both the Qty and +per (m) fields then the input quantity is added to the 

calculated total number of Bolts per meter. 

 

Clips: This field is used to select the type and price of Clips for a connector. These should be set up 

in the Clips section of the Ancillaries tab in the Pattern Database. 

 

Qty: Specifies a set quantity of Clips required for a single connector. 

 

+ per (m): Specifies the number of Clips required per meter. The Number of Clips is calculated 

individually for each of the four adjusted profiles. The totals are then added together. 

If a value is entered in both the Qty and +per (m) fields then the input quantity is added to the 

calculated total number of Clips per meter. 

 

Gasket: This field is used to select the type and price of Gasket required for each connector. These 

should be set up in the Gasket section of the Ancillaries tab in the Pattern Database. 

 

Shared Gasket: This section determines the total amount of Gasket used per connector. If Yes is 

selected the software will calculate the amount of gasket required per connector (using the Gasket 

field above) and then halve it. This is necessary because only one gasket is required for every two 

connectors. If No is selected then the calculation from the Gasket field above will be left unchanged. 

 

Step by Step 

 

� Open the Pattern Database and locate the Connectors section. 

� Select the DM-25 connector to amend. 

� Apply a -3mm (minus three) allowance to the Turnover to allow for the thickness of the 

flange so the finished length of the duct is correct.  Without this a Duct size of 1500mm 

would finish as 1506mm when the DM-25 connectors are added to it. 

� Click the Estimating Icon to switch the view over to Estimating. 

� Select the connector you require to apply the ancillary materials to. 

� Apply using the drop down lists available your materials and quantities where required i.e. 

for clips and corners etc. 

� Click Close to confirm changes. 

� Create a job with a Rectangular Straight piece in and apply your connector to both C1 and 

C2. 

� Accept the part into the Job 

� Right Click on the item in your Job and select Edit Developments. 

� The Black outline is the size input in take-off, the white line is the size it will cut.  You will see 

that the white line is 3mm inside the Black line. 
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� Click Cancel to return to Job Contents. 

� Right Click on the item in your Job and select Cost Breakdown 

� Expand all branches under Material Costs > Ancillary Cost and you should find that the costs 

of connector materials etc have all been applied. See below: 

 

 
 

Areas Covered 

 

Connector Allowances 

Ancillary costs for Connectors 

Cost Breakdown for Connector Costs 

 

Completed q 
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5.3 Stiffeners 

 

Aim 

 

To create Stiffeners settings for Ductwork that requires strengthening. 

 

Details 

 

Stiffeners are required by some ductwork specifications for strengthening. To access and amend 

these settings Click on File > Setup > Pattern Database and select the Stiffeners tab or select 

the Pattern Database icon from the Utility Bar. 

 

Manufacturing Properties   

 

Click the Manufacturing button.  

Double-click an entry to change details.  

Right-click and choose New to create a new stiffener or click on the new icon.  

  

 
 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 46 of 166 

 

 
Name 

A descriptive identification can be entered that will help to identify the stiffener. 

 

Central Type 

Selects and sets the type of stiffener to be used centrally on the duct. This is only a reference for 

the user as the program calculations do not vary depending on the type selected. The pulldown 

menu contains the following types. 

 

None 

No Stiffener placement.  

Internal 

Central Tie Rods placement only.  

External 

External Central Stiffener placement only.  

Both 

External Central Stiffener and Central Tie Rods placement.  

 

End Type 

Sets the type of stiffener to be used at each end of the duct.  This is only a reference for the user as 

the program calculations do not vary as to the type selected. These settings are the same as those 

listed in Central Type. 

 

Adjust Long/Slide 

Adjusts the stiffener length to allow for the correct fitting of the corner piece or for welding, on the 

ducts longest side. 

 

Adjust Short/Drive 

Adjusts the stiffener length to allow for the correct fitting of the corner piece or for welding, on the 

ducts shortest side. 

 

The figures in these fields are added to the shortest dimension for the ducting. If, for example, the 

ducting in the diagram has a width of 300, and the Adjust Long / Slide value is set to +100, then 

the stiffener length on reports will show the length as being 400. 

 

LS Only < 

When the shortest side of the duct falls below the value entered, the stiffener is calculated as Long 

Side only. 
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Tie Rod Hole Diameter 

The diameter of holes for the attachment of the tie rods. 

 

Central Tie Rod Offset (Width) 

Adjusting these values will alter the gap distance between the central external stiffener and the 

internal tie rod stiffener. 

 

Connector Tie Rod Offset (Width) 

Adjusting this value alters the gap distance between the internal stiffener and the end connector. 

 

Central Tie Rod Offset (Depth) 

Adjusting these values will alter the gap distance between the central external stiffener and the 

internal tie rod stiffener. 

 

Connector Tie Rod Offset (Depth) 

Adjusting this value alters the gap distance between the internal stiffener and the end connector. 

 

Tie Rod Extension  

States the amount of the tie rod which will be visible on the underside of the ductwork. 

 

 

Tie Rods... (Button) 

Clicking on this button brings up the Tie Rods Qties Window.  This Window is used to setup and 

configure the breakpoints that determine the quantity and position of the tie rods used on the 

pattern. 

 

 
 

The Tie Rod Qties information is shared between the Manufacturing and Estimating properties.   

 

Step by Step. 

 

• Click on the New icon.  

• Enter the breakpoint dimension in the <=Width (Less than or Equal) field.  

• Enter the number of central tie rods used for this dimension in the Centre Tie Rods field.  

• Enter the number of end tie rods used for this dimension in the End Tie Rods field.  

• Multiple breakpoints can be entered to allow for differing numbers and combinations of tie 

rods to be used with different widths of duct.  

• Click OK when finished.  
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Areas Covered 

 

Setting up of Stiffener types 

Creation of Stiffener breakpoints 

 

 

Completed q 
 

 

 

5.4 Splitters 

 

Aim 

 

To create, and apply, Splitter settings for Rectangular Duct. 

 

Details 

 
Splitter Vanes are required by some ductwork specifications to smooth the air-flow around bends. 

Splitters can be applied to several of the Radius Elbow patterns. To access and amend these 

settings Click File > Setup > Pattern Database and click on the Splitters tab or select the 

Pattern Database icon from the Utility Bar. 

 

 
 

Manufacturing Settings  

• Click the Manufacturing button.   

• Double-click an entry to change the values.   

• Right-click and choose New to create a new entry or click on the new icon.  

 

 

Name 

Enter a description to identify the Splitter. 
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Min Angle 

Enter the Minimum Bend Angle greater than and including the value at which Splitters are required. 

Typically this will be 45, 75 or 89 degrees. 

 

Width Adjust 

This allowance can be positive or negative dependent on how the Splitter Vanes are Fitted. The 

value is added to or subtracted from the Vane Width. 

 

Note: As soon as a positive figure is entered in the Width Adjust field, the program will assume 

that the splitter is to be kinked, and the length adjusted accordingly. 

 

Length Adjust 

The calculated Vane length can be adjusted for an allowance that can be rolled over to form a safety 

edge. This value is added to or subtracted from the Vane Length. 

 

Inset 

Determines the Inset from the Radius point at which the Vane will start. 

 

Hole Spacing 

If Splitter Vane fixing Holes are to be Marked or Cut, enter the value for the Hole spacing. 

 

Hole Size 

The options are 

 

Pierce: The Plasma Torch will pierce at the Hole centre.  

Mark:   The Marker Tool will Mark the centre of the Hole.  

Value:  Enter the Diameter of the Hole to be cut.  

Machine Cut: Toggle Yes or No. 

 

Min Width / Throat 

Sets a minimum size the width / throat must be before splitters are required. 

 

Hole Inset 

Determines the distance from the edge of the splitter that the first and last hole will be. 

 

Length includes Extensions 

Toggle Yes or No. 

 

Fixing Holes in Turnover 

This field determines whether or not fixing holes will be placed in the turnover or not. 

 

Tab Width 

This field determines the width of the tabs on the turnover, choose either Yes or No 

 

Tab Vee Notch Angle 

This field allows the user to set the angle of the vee notch that will be placed in the turnover. 

 

The splitter now needs breakpoints applying to it. This allows different amounts of splitters to be 

produced for different widths of duct. 

 

Breakpoints 

Click on the Breakpoints button to access the Breakpoints dialogue. 
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Position Units 

Two methods for calculating splitter spacing are available when you click the Breakpoints tab. 

Choose the method required: 

 

Positions are a distance from the throat 

When this option is used the Vane positions entered for fields #1, #2, and #3 are absolute 

distances from the centre of Bend Radii.  The <=Width (less than or equal to) field will determine 

when the breakpoint will be applied.  In the example above, a duct with a width of less than 

399.9mm, will not have splitters applied.  A duct with a width of less than 800 but greater than 

399.9 would get 1 splitter.  

 

Positions are a percentage of the Duct Width from the throat 

When this option is used the Vane positions entered for fields  #1, #2, and #3 are percentages of 

the Duct Width taken from the centre of the Bend Radii. The <=Width (less than or equal to) field 

will determine when the breakpoint will be applied as explained above.  In this case however, the 

figures in put in the 3 fields would normally be around 50% for 1 splitter, 33.3% and 66.6% for 2 

splitters and 25%, 50% and 75% for 3 splitters. 

 

Step by Step 

 

• Select a Radius Bend from the Rectangular Item Files folder. 

• Depending on the Specification being used you may have to apply the Splitter manually, 

ensure the Splitter selection box is available on the Item tab, if not place it on the Item tab 

through the Customise Menu. 

• Change the Throat radius to a value less than Half the Width.  

• Apply the Splitter to the Bend. 

 

 

Areas Covered  

 
Creation of Splitters in the Pattern Database 

Creation of Breakpoints for Splitters 

Applying the Splitter to an Item 

 

Completed q 
 
 
 

5.5 Airturns 
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Aim 

 

To create and configure the Airturn settings for rectangular Duct. 

 
Details 

 

Square bends and tees often require air turning vanes to be fitted to assist the air flow. Different 

suppliers and types of airturns can be set up in the database. The main objective is to produce 

management reports that detail the airturn materials used and the airturn assembly cutting lists.  

To access the Airturn Database Click on File > Setup > Pattern Database > Airturns or select 

the Pattern Database icon from the Utility Bar. 

 

 
 
Double clicking on an entry, within the table, will bring up the following screen to allow you to edit 

the airturn details, clicking on the new Icon will create a new Airturn entry. 
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The options available in the database are as follows: 

 

Name 

The airturn is given a name for identification purposes. 

 

Vane Spacing 

The Vane Spacing dialogue allows the user to specify the distance, between the vanes, along the 

track. 

 

Track Width 

The Track Width dialogue allows the user to specify the width of the track onto which the Vanes are 

to be inserted. This is also used to aid in the calculation of the vanes by adjusting the calculated 

distance based on how far the track can be pushed into the back of the bend.  If vanes need to be 

calculated from the throat of the bend, all the way to the back, set this value to zero.  

 

Qty. Adjust 

Can be used to add or subtract from the number of calculated vanes. 

 

Track Length Adjust 

The track length adjust value is subtracted from the calculated length of the track. This may also 

affect the number of calculated vanes. 

 

Vane Length Adjust 

The vane length is calculated from the duct depth, minus the value entered into the Vane Length 

Adjust. 

 

Min. Angle 

Airturns will not be applied if the fitting is entered with an angle less than this value. 

 

Min. Length 

Refers to the minimum length of track. If the calculated track length falls below this value then the 

Airturn will not be applied to the fitting. 

 

Max. Length 

Refers to the maximum length of track. If the calculated track length rises above this value then the 

Airturn will not be applied to the fitting. 
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Bank Type 

Can be set to either Multiple Banks or Single Stiffened.  Multiple Banks will look at the Depth of the 

Duct and the Maximum Vane Length and calculate the number of sets of Airturns to fit. 

 

Vane Hole Diameter 

This option allows the user to specify whether the vane connecting holes should be pierced, marked, 

omitted or specified with a value. 

 

Track Hole Diameter 

This option to specify whether the track connecting holes should be pieced, marked, omitted or 

specified with a value. If the hole diameter is selected as Pierced or a Value then the Fitting cheek 

panels will be cut with the holes. 

 

Track Hole Spacing 

The value entered here will specify the distance between the track connector holes in the column for 

fixing to the duct. 

 

Track Hole Separation 

This option allows the user to specify the distance between the two sets of track connecting holes. 

 

Printing Airturn Reports 

A print report can summarise the Airturn material requirements and cutting list.  

 

 
 

Track Lengths, Vane Length, and Vane Quantity are all calculated using the following: 

 

Track 

For the example above a 600 x 400 Square Bend would produce an unadjusted length of  

SQRT (600²mm + 600²mm ) = 848.5mm. 
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Because the Track Width = 100mm, it will not fit exactly in the corner, the corner adjust will be 

50mm. 

The Track Length Adjust from the table = -8mm. 

So the adjusted Track Length will equal 848.5mm - 50mm - 8mm = 790.5mm. 

 

Vane Length 

Duct Width = 400mm. 

Vane Length Adjust from the table = -12mm which allows for Track Thickness and Duct Gauge. 

So the adjusted Vane Length equals 400mm - 12mm = 388mm. 

 

Vane Quantity 

Vane Spacing from the table = 100mm 

The quantity is calculated using the adjusted Track Length divided by Vane Spacing which equals 

790.5mm /100mm = 7mm (rounded down). 

1 vane is deducted from this to allow for the corner fitting. 

Number of Vanes = 6 

 

If needed the Qty Adjust can be used to make the quantity of vanes increase or decrease. 

 
Areas Covered 

 

Setting up of Airturn Parameters 

Creation and breakdown of the Airturn report 

 

Completed q 
 

 

5.6 Notches 

 

Aim 

 

To create, setup, and apply, the Notching of Connectors and Seams. 

 

Details 

 

The notches option allows the connectors that are used on rectangular ducts to be modified for the 

development of the ductwork that they are applied to.  This is illustrated in the example below. 

Without the removal of the seam, the flange allowance could be run through the same seaming 

procedure as the rest of the seam. 

 

Creating Notches 

Notches cannot be applied to a development directly. To apply a notch you must first associate it 

with a connector. Notches are configured from the notches dialogue in the pattern database. 

 

• Click on File > Setup > Pattern Database or select the Pattern Database icon from the 

Utility Bar.  

• Click on the Notches tab  

• The Notches dialogue will be displayed. 
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Print / Print Preview Icon  

Clicking on this button will preview the notch settings with an option to print them. 

 

Display Seam 

Allows the user to change the seam that is displayed in the notch preview windows. This does not 

have a direct effect on the notch, but is useful for visualising the notch when in the creation 

process. The list of seams is taken from the seam database. 

 

Male Angle 

Sets the angle to which the male seam will be cut. 

 

Female Angle 

Sets the angle to which the female seam will be cut. 

 

Notch (Pulldown Menu) 

Displays a list of the currently configured notches. It is inadvisable to change any of the pre-defined 

notches if you are not sure where they are used. It is safer to create a new notch as there are no 

limits to the number of new notches creatable.  

 

To create a new notch 

 

• Click the new icon to the right of the pulldown menu.  

• You will be asked if you want to copy the settings from the currently selected notch.  If this 

notch is similar to the one you want to create click Yes.  If you want to start from scratch, 

click No.  

• The  delete icon is used if you want to delete a notch.  

•  

Automated Functions 

There are two options to assist in the creation of the notch.  These options allow the most common 

notches to be applied without specifying actual sizes.  These settings are Notch Out and Remove 
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Taper Extensions. Both of these settings have separate male and female settings so that they can 

be applied to the correct developments. 

 

Notch Out 

This removes the material where the seam and connector allowances meet. 

 

Remove Taper Extensions 

As it is quite common that a part cannot be turned whilst seaming, it is necessary to remove any 

material that might catch during the process, or at least limit the effect. An good example of this is 

on the taper fitting.  

 

Notch Definition 

The boxes below the Notch Out and Remove Taper Extension checkboxes can then be used to enter 

the dimensions of the notch.   

 

Step by Step 

 

• Click on the new icon to the right of the Notch pulldown menu.  

• You should receive a prompt asking whether you wish to make a copy of the existing notch, 

click No.  

• Give the notch a different name to all the other notches in the list.  

• Create a new set of entries under the Male column by clicking the new icon on the left hand 

side of the male column.  

• In the Male X box, type 40.  

• In the same way, enter 40 in the Male Y box.  

• Enter 40 for the Female X box.  

• Enter 40 for the Female Y box.  

• Select a seam to display with the notch by selecting PITTS-S from the Display Seam 

pulldown box.  

• You should now have a notch which is ready for use in your job (for example, to be 

associated with a connector).  

 

Note that the Y= lengths are both longer than the values you have entered in, in this case 40 for 

each.  This is because it is adding the Y= allowance to the seam allowance, as defined under the 

seams tab. 

 

• Click Apply followed by OK to save the changes to your database and exit the dialogue. 

 

Areas Covered 

 

The creation and application of a Notch, and how it affects the Seam. 

 

Completed q 
 

 

5.7 Specifications 

 

Aim 

 

To explain what specifications are, how they are used and how these can be applied within the 

manufacturing environment. 

 

Details 

 

The specification function from within our software is a way of automatically applying standards as 

parts are entered into the job. 

 

Around the world there are many different specifications for ductwork that define manufacturing / 

construction standards to be used when working with those products. 
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Specifications will automatically select key areas of the part, material thickness, connectors to be 

used, seams assigned, stiffeners etc. Specifications ensure correct component and attributes are 

assigned to the part which automates the task for the user. 

 

 
 

The specification tables can be setup in a number of ways. The most common type of breakpoint, 

for specification setup, is Single dimensions breakpoint and would only represent the longer side of 

the ductwork in rectangular, the diameter for round and the major axis on flat oval. 

 

 
 

The Specification name can be defined when creating a new specification or the drop down list will 

display the available selection currently within your database. 

 

The Material type for the entered part can be set for that specific specification. You can have sub-

sets of materials for each specification type. This allows for varying entries dependant on material 

type. If a material has not been selected or setup within the specification, that material would not 

be available when entering the part and therefore not apply the specification breakpoint rules. 

 

Specifications are also sub-divided by Library. The most common libraries used being 

Rectangular, Round and Oval. 

 

The different parameters that can be changed on an entry are as follows: 
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<=Dim: Dimensions inserted into here would be less than or equal to. 

 

Gauge: Material thickness for a part can be selected via the drop down 

 

Connector In: The connector that is to be placed on the inlet end of a fitting. 

 

STD Straight: Length which is the Material width or coil width. 

 

Connector Out: You can optionally specify a connector out but leaving as Not Used will continue to 

use the same as used in the Connector In. 

 

Seam: Type of seam used 

 

Stiffener: Type used with a spacing value applied. 

 

Support type or hanger again with a spacing value 

 

Sealant: Select a sealant to be assigned. 

 

Standards for Splitters on Radius bends 

 

Airturn: For Square bends and Tee’s.  

 

Drop down list options are applicable for most of these options for setting the required values. 
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It is possible to make multiple changes to the specification table. If for instance you wanted to 

change all of the STD Straight length values in the column. You can multiple select the whole table 

by highlighting the fields with the mouse, right click on the values, choose Edit and you can make 

global changes to the selected fields using the dialogue box as shown below: 

 

 
 

Normal housekeeping type functions are additionally available when editing the specification table. 

Right clicking on items enables you to Edit, New, Cut, Copy, Paste and Delete. 
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Spec tables can be categorized for Straights and Fittings if you wanted to differentiate between the 

two types using the Valid for drop down. This enable the use of separate seams etc for Straights 

than you would with bends, t-pieces and transitions. 

 

 
 

 
 

There are a number of ways to setup the specification table based on the dimensions you want to 

create the breakpoint table with. 

 

Single Dimension: most commonly used to differentiate the long side/diameter/major axis. 

 

LS / SS Dimensions: this would allow for more scope on accuracy for example when using 

stiffening configurations – you can specify a more detailed setup by using long side by short side 

breakpoint tables. 
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Single Dimensions + Length: would have the Length tabs across the top to be more specific 

when using a singular dimension breakpoint table. 

 

LS / SS + Length: is the most accurate breakpoint table as this is using long side by short side 

dimensions with individual length tabs across the top for complete control over the specification. 

 

Specifications that bring in a length based breakpoints use a tabbed system at the top of the 

specification table allowing for the tables to be defined into length categories. When creating a 

length based specification there is an additional option to Stiffen by quantity or by spacing. 

 

 
 

Importing and Exporting Specifications 

 

Specifications can be easily imported and exported if sharing with other users. File > Import > 

Specifications or File > Export > Specifications allows for your to select the specification wanting to 

be imported/exported into/from your database.  

 

 
 

This will also bring through any new connectors / seams etc that maybe used within the 

specification that are not already available in your database. There is also the ability to preview 

specification prior to importing by selecting the Edit option as shown below. 
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When creating new specification tables, there maybe an occasion where you would want to bring in 

other tables from other specs but not actually copy the whole specification itself. There is a copy 

icon that allows for you to select the appropriate table which is located to the right of the Library 

option shown below: 

 

 
 

Printing Specification Tables 

 

Printing of the specification can be selected via the print preview icon shown at the top left next to 

the Specification field in the below image. Clicking the icon will result in you being able to print the 

active specification or if All is selected when prompted, enable all Specifications to be printed in 

your database. 

 

 
 

Apply Specifications 

 

We will discuss the ability to assign specifications to your items in your estimating software. 

 

One area where we can apply specifications is the Job Browser window. This allows you to apply 

specification to your whole folders and restricting specifications to that specific folder only. This 

would allow for automation in the job creation procedure so all items within the folder are restricted 

to a specification(s) and therefore cannot be mistaken with other specification tables. Select the Job 

Browser > Edit Project Information when selecting the folder in your structure. 
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. 

 

Within Item Folders: You can apply specification to multiple items by multiple selecting, then right 

clicking on the selected item(s) and using Change Specification option. This will default the 

specification used to the chosen one for the item(s) 

 

 
 

Step by Step 

 

� Navigate to the Pattern Database > Specification section. 

� Create a specification for you to apply to your items. Decide on whether this would be Single 

dimension or multiple dimension based. 

� Ensure the breakpoint table for All/Straights/Fittings are setup correctly by copying over 

tables if required for each individual type. 

� Ensure the connectors being applied are correct dependant on size 

� Ensure Stiffeners / Supports etc are all ok. 

� Make multiple changes to a property by highlighting multiple rows and making the same 

change to them all globally 

� Confirm all the changes and select OK. 

� Apply the amended specification to your items. 

� Ensure the specification is being pulled through by testing your specification on multiple 

variations of the same item. 

 

Areas Covered 

 

Specification Overview 

Specification types 

Editing Specifications 

Creating New Specification Tables 

Importing/Exporting Specifications 
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Corner Costs/Weights 

Bolt Costs/Weights 

Clips Costs/Weights 

Gasket Costs/Weights 

Connector Item/Fitting 

Applying Specifications to Items 

 

Completed q 
 

 
 
 

5.8 Ancillaries 

 

Aim 

 

To create ancillary materials for your connectors, clips, supports and stiffeners etc. 

 

Details 

 

The Ancillary items, such as Corners, Bolts, and Gasket etc, are setup in the Ancillary section of the 

Pattern Database. These values are stored in lists which are then linked to their respective item. The 

diagram below shows visually how this is works for a Connector. 

  

 

The principle is the same for other costed Ancillaries such as Airturns and Supports. The advantage 

of using this method is that a price list can be used more than once. This is more convenient when 

setting up like items e.g. A Ductmate Connector and a Ductmate Stiffener. Both these Items can use 

the same Corners, Profiles and Bolts so the same Costs/Weights lists can be assigned to each. 

 

Nearly all of the Items in Pattern Database, Connectors & Stiffeners etc use multiple entries from 

the Ancillary tables. A list of the required tables and their locations are displayed below: 

 

Connectors 

Table Used Ancillary used 

Material Ancillary Materials 

Corners Corners 

Gasket Gasket 

Clips Clips 

Bolts Fixings 

 

Stiffeners 

Table Used Ancillary used 

Material Ancillary Materials 

Tie Rods Tie Rods 

Bolts Fixings 

 

Splitters 

Table Used Ancillary used 

Fixing Type Fixings 

 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 65 of 166 

 

Airturns 

Table Used Ancillary used 

Track Type Airturn Tracks 

Centre Track Type Airturn Tracks 

Vane Type Airturn Vanes 

Outside Fixing Type Fixings 

Central Fixings 

 

Supports 

Table Used Ancillary used 

Bolts Fixings 

Clips Clips 

Top Fixings Fixings 

Insert Type Ancillary Materials 

 

Step by Step 

 

� Open the Pattern Database and locate the Ancillary section. 

� Select the Ancillary Material type and create a new entry – You could use an existing material 

if required if cost is known as this material will be eventually be applied to a connector. 

� Enter a cost per meter for this item by editing the properties. 

� Select Clips and then also Corners etc and enter a cost per quantity for each of these items – 

either creating new items or selecting existing entries. 

� Confirm your changes by selecting OK. 

 

Areas Covered 

 

Ancillary Material Setup 

Ancillary Table association  

 

Completed q 
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5.8.1 Item Ancillaries 

 

Aim 

 

To attain the knowledge of assigning ancillary materials to each individual item within your item 

folder structure should your require additional costs creating 

 

Details 

 

There is the option to assign free entry ancillaries that have already been preset in your database. 

 

 
 

Right Clicking on the items within your Item Folders and then selecting Properties will allow you 

to access the Ancillaries tab as shown above. Here you can define the ancillaries that are to be 

applied to the item and also the labour rates that have been assigned for that ancillary. 

 

 
 

The Free Entry Ancillaries window allows you to provide a name for the ancillary and a section type 

for where the ancillary is located in the database. The calculated cost of which will be the value 

entered in the ancillary database in the Estimating section. 

 

Step by Step 

 

� Ensure the ancillary requiring to be assigned to the item has already been created within the 

database and it contains a cost. 

� Select your item from Item Folders and click Properties to select the Ancillaries tab. 

� Define the ancillary types you require to be assigned. 

� Confirm your ancillary additions by selecting OK. 

� Select from the drop down the ancillary required. In some cases there maybe quantity fields 

to choose and/or spacing requirements. 
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� Add the item to the job and view the cost breakdown and ensure the cost of the extra 

ancillary has been applied correctly. 

 

Areas Covered 

 

Assigning Ancillaries to individual Items 

 

Completed q 
 

 

5.8.2 Ancillary Kits 

 

Aim 

 

The ability to create a list of ancillaries that are all combined to make up an ancillary kit. 

 

Details 

 

Ancillaries have always been a large part of the CAM-Duct and EST-Duct software packages in that 

by using a combination of Ancillary Materials, Fixings, Support Rods, Corners etc we can get a 

material cost, and weight of a completed fitting. 

 

For example, if you wanted to create your own support costs, this would be possible with the use of 

ancillaries and kits. 

 

From with the Pattern Database > Ancillaries > and Ancillary Kits selection from the drop down 

menu, we can create a kit that consists of a number of ancillaries. It is also possible to have kits 

within kits if necessary. 

 

 
 

As shown above, we can specify the quantities of each ancillary added to the kit, together with 

length, unit of measurement and the width / depth. 

 

The example I have used to demonstrate the ancillary kit is a new support type that has two top 

fixings, two stirrup bearers, two cleats, two tie rods and the relevant bolts & washers. 
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The above diagram of a support is costed below. 

 

 
 

If we view the Cost breakdown for the Floor Ring Kit as shown above, we can see that this consists 

of the quantities we assigned earlier in this demonstration. We can construct the kit to suit our 

requirements. 

 

The kit can contain a number of ancillaries. Each ancillary can be allocated a product ID which is 

then cross referenced in a price list for example. These codes can then be reported and called upon 

to report a cost for the build up of the kit. 

 

 

5.9 Pattern Options 

 
Aim  

 
To gain an understanding of how the pattern options can globally affect the development of 

Patterns. 

 

Details 

 
There are a variety of different options within the pattern options settings that influence how 

Notches, Connectors and Seams are defined within the program. 

 

Click File > Setup > Pattern Database > Pattern Options or select the Pattern Database icon 

from the Utility Bar.  
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Number of Round Sections 

The Views setting controls the number of faces used to model circular & oval ducts in 'Takeoff' 

views.  

Click on Developments to control the number of lines the circular profiling sections are made up 

from. In general the higher this number, the more accurately circular profiles will be cut.  

The <=Diameter column defines the breakpoints at which the number of development lines will 

increase.  The Value column on the right is the number of circular sections for the given diameter 

and can be altered by clicking in the box and adjusting the value in increments of 24 via the 

Up/Down arrows.  Use the Green 'New' icon to create an additional diameter breakpoint or the red 

cross 'Delete' symbol to remove a breakpoint. 

 

Default Connectors 

Specifies the default Connector that will be used for Rectangular and Circular duct if no Specification 

is applied. The connectors available are taken directly from the connectors that are set up in the 

Connector database. 

 

DIN 

 

The DIN option is specific to German users only.  

 

ANFACA 

 

The ANFACA option is specific to Spanish users only.  

 

Duct Board 

Duct Board is a phenolic foam duct system that uses specific patterns created by MAP for cutting on 

a router based cutting table. Clicking on this button will open a window for editing Duct Board 

specific options  

 

 

 

Alternate Throat Seams 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 70 of 166 

 

 

 
 

On some rectangular fittings it is necessary to use a different seam for the throat than that used on 

the rest of the duct. The normal seam can be entered during pattern takeoff, but if the throat part 

of the fitting falls into the criteria set here, these settings will be used to generate its seam. If the 

throat length of a fitting is equal to or less than the value entered in the Throat Length field.  The 

seam set up in the Use Seam field will be used. There are also options to Remove Connector 

Notches and Remove Vee Notches, tick as appropriate.  

 

Castle Holes 

This option allows the user to set the size and angle of tabs applied to Castellated Holes. 

 

 
 

In the Length field enter the relevant Length of the Castellated tab.  

The Width field sets the width of the tab. 

The Angle field sets the angle at which the tabs will be cut.  

 

Circ/Oval Dev 

This option allows the user to define how circular and oval developments are calculated. The three 

diameter types of a circular pipe or fitting are Nominal, Inside and Outside. The terms apply to the 

position from which a diameter is measured. For further information refer to the “A Definition of 

Circular Developments” topic in the On-line help. 

 

Connector Slits 

Connector slits are set up here. These are slits that run parallel to a rectangular connector end, and 

are primarily used for attaching clip-on connectors. 

 

 
 

The Length field sets the length of each slit.  

The Inset field sets the distance of the slit from the end of the duct before allowances are allowed. 

This must be less than the allowance for the connector or slits will not be added.  

The Centres field sets the distance between the centres of adjacent slits. If the duct end is smaller 

than this distance, slits will not be added.  

Note: The first and last slit will be inset from the side of the duct by the centres value. Slits are 

currently cut with zero width. 

 

LUKA 

The LUKA option is specific to Dutch users only.  

 

 

 

 

Hole Stitching 
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This option sets the default number of stitches and the gap size for cutting inner island holes in a 

part. 

 

 
 

The Gaps field sets the distance between stitches to apply to the cutting of a hole.  

The Quantity field sets the default number of stitches to apply to the cutting of a hole.  

 

 

Clip Holes 

Clip holes are used for Valve boxes and Lagging. The option needs to be enabled for individual 

patterns. Click the Clip Holes button and the Clip Holes dialogue box will appear.  

 

 
 

The Clip Hole Diameter sets the diameter of the hole used to attach the clip to the pattern.  

The 2 Clip C/L Distance sets the value of the Centre Line offset if using 2 rows of holes.  

The 2 Clip Break Length: If the length exceeds this value the number of clips is doubled.  

The Lap / No Lap field sets the Lap size with allowance or without allowance  

The Sepn field sets the distance between the 2 holes.  

Inset sets the inset distance from the end of the part.  

 

Straights 

The Straight option works solely when using Pattern Number 866. This pattern allows the user to 

produce straight, using either a decoiler or a plasma cutter. The criteria for defining which process 

will be used is briefly explained on the next page. 
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The Machine Cut section allows the user to set a criteria which will determine when the Straight 

will be machine cut and how it will be formed. 

 

The Machine If Length< field allows the user to enter a value. If the length of duct is shorter than 

this value it will be machine cut.  

If all four sides of the duct are below the value set in the Machine If Sides< field, the straight will 

be machine cut.  

If the shortest sides of the duct is less than the value entered in the Machine if Short Side< field, 

the straight will be machine cut.  

If the Longest side of the duct is greater than the value entered in the Machine If Longest Side> 

field, the straight will be machine cut.  

If any of the above criteria is met, the straight will be machine cut; otherwise the program will use 

the Decoiler options to see if the straight can be decoiled. 

 

The following options will determine how the machine cut straight will be formed. 

 

Straight Type: This option sets the default type of straight to be plasma cut. If the straight is too 

large to fit on the sheet, the other types will be tried in the following sequence, beginning with the 

default type: 1 Part Straight; 1xU, 1xI; 2xL; 4xI,M-M,F-F; 4xI,M-F  

Female Allowance: Determines the side of the fitting to which the female seam allowance is 

applied when there is a choice. 

1xU 1xI: Determines which side forms the single panel when the straight is cut as a 1xU, 1xI type  

4 Part If Long Side >: If the longest side of the straight is above this value then it will always be 

cut in 4 parts.  



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 73 of 166 

 

4 Part Always M-F: If enabled then the program will always put a male and female seam 

allowance on each panel when the straight is cut in 4 parts. If disabled, each panel would normally 

have 2 male or 2 female allowances unless this made the panel too large to fit on the sheet.  

Use Auto Length as Entered Length: 

 

The Decoiler section allows the user to set how straight will be formed via the Decoiler. 

Note: These options apply only when the Machine Cut options have determined that the straight 

should not be machine cut. 

 

Standard Lengths 

The Standard Lengths section contains a list of lengths that are determined to be Standard, i.e. you 

may have coils that are different widths but each coil would produce a straight standard to it.  

 

To add another entry click the new icon. To remove an entry set its value to Zero  

Note: The standard lengths table is not a collection of breakpoints, each entry must be matched 

exactly by the entered duct length. In most cases it is recommended that standard straight lengths 

be set up in the Specifications table in the Pattern Database rather than being entered in this table. 

If the length of the straight does not fall into the standard lengths list, the straight will be processed 

as if it were the normal coil straight fitting, Pattern CID 35. In this case standard straight lengths 

are defined in the Specifications table in the pattern database. 

 

If the Always tickbox is enabled, all straights entered using pattern 866 are treated as standard 

straights. If disabled, only straights of standard length are treated as standard; all others are 

treated as non-standard.  

Max Stretchout (Standard) & Max Stretchout (Non Std): Determines the maximum length of 

any single decoiled part for standard and non-standard straight lengths. An example of this would 

be if you were decoiling the sheet to fold in a press break and not on the coil-line. The length of the 

sheet could be too long, making it difficult to handle. Once the length goes over this size, the 

straight type will be set to be made in 1xU, 1xI , then 2xL, until it fits.  

Note: Entering large values will ensure that straights are made in 1 piece, subject to the other 

options. 

 

Maximum Fold Length: Determines the largest fold allowed.  

Minimum Fold Length: Determines the smallest fold allowed. Both the maximum and minimum 

fold lengths are used to determine the final straight type. A 1 piece or 1xU, 1xI straight must 

satisfy both the maximum fold length and the minimum fold length check. If it fails, the type will be 

set to 2xL. This type will be used if it satisfies either of the minimum or maximum checks. Failing 

this check will set the straight to be made in 4xI sections.  

Minimum Side For 2 Folds: Determines the smallest side allowed when a part has more than 1 

fold. If the smallest side falls below this value, the straight will never be made as a 1 Part or 1xU, 

1xI type.  

Allow U+I: If disabled the straight will never be made as a 1xU, 1xI type.  

Allow 4-Part: If disabled the straight will never be made in 4 parts.  

Machine Cut If Cannot Decoil: This option is only used when the previous options for the decoiler 

do not produce any valid straight types. The most common reason for this is that the checks have 

determined that only a 4-part straight is valid but the 'Allow 4-Part' option is disabled.  

If this switch is enabled, the program will set the straight to be plasma cut, using the Machine Cut 

options, but it will ignore the checks to decide if it should be machine cut. If this switch is disabled, 

the program will report the straight as being invalid.  

4 Part Always M-F: If enabled then the program will always put a male and female seam 

allowance on each panel when the straight is cut in 4 parts. If disabled, each panel would normally 

have 2 male or 2 female allowances unless this made the panel too large.  

Allow Split Sides: This feature has been implemented for certain decoilers and should not be 

activated for general use.  
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Fixing Holes 

Fixing Holes are mainly used with Insulation Patterns, and these holes can be applied to the seam of 

a pattern. The settings here determine how these holes are applied. 

 

Click on the Fixing Holes button  

 
 

The Hole Diameter field sets the diameter of the hole to be cut.  

The Hole Inset can be determined in two ways. The first is by setting a specific distance. In the 

Distance field, the value entered here will be the distance in, from either end of a section of a 

developed fitting. In the Fraction field, the value entered here will be the amount that any 

developed section of a fitting will be divided into to determine the inset position of the fixing holes.   

Note: If an amount has been entered into the Distance field, the Fraction field will be automatically 

over-ridden. Before the Fixing Holes can be used the Items tab within the patterns themselves has 

to be customized. To do this, follow these steps: 

 

• Click Utilities > Item Folders  

• Click on the Round folder. Locate the Segment Elbow icon and right click on it.  

• From the pop - up menu select Edit  

• The Editing Pattern Defaults view of the Segmented Elbow will now be visible.  

• Click on the Item tab.  The Items will look similar to the one below.  

 

 
 

Along to top of the PM2000 window click Takeoff > Customize the following window will appear.  

Click on the Item Information tab  
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The dialogue box that appears is split into two sections. The section on the left displays all the 

options that can appear in the Item tab and the section on the right shows the options that already 

appear in the Item tab.  

• In the left hand section locate the option called Fixing Holes and click on it.  

• Once it is highlighted, it needs to be moved to the right hand column. This is be done by 

clicking on the arrow pointing towards the right.  

• The Fixing Holes option should now appear on the right, click OK  

• The Item tab should now have the Fixing Holes tick box displayed.  

 

 
 

Ticking this box will enable the Fixing Hole settings that have been mentioned earlier.  

This option will now appear in every fitting where Fixing Holes can be applied.  

 

 

Notches 

The Notches option allows the user to set up default notches that are used throughout CAM-Duct 

Click on the Notches button and the following window will appear.  
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Marker Notch 

The Marker Notch option allows the user to mark centrelines and fold lines on developments. The 

depth and angle of these points can be configured here by entering values into the relevant fields. 

Different Marker Notches can be set up different pattern types. 

• In the Depth field enter the required depth of marker notch for Rectangular, Round and Flat 

Oval fittings.  

• The Angle field sets the angle at which the notches will be cut.  

• Enabling the Use on Rolled Circular Branches option will place a marker notch at the front 

and the back of the circular branch.  

• The Hole option allows the user to set a separate marker notch definition for holes. Click the 

Outside option to enable this option.  

Vee Notch 

This option allows the user to set a notch configuration for additional notches. This is set in the 

same way as the Marker Notches.  

Notch for Connector Split 

Specifies the default notch for connector split. The notch type is taken from the notches that are set 

up in the database. 

Number Of Fold Notches 

The number of fold notches denotes how many notches are to be cut out of a given size of duct to 

mark where it is to be folded. Fold notches are used for marking out where the duct is folded from. 

The values are: 

 

None = No Fold Notches. 

8, 12, 24 = Set values. 

Max = Maximum amount per part. 

Max/2 = Half of the maximum amount. 

Max/3 = One Third of the maximum amount. 

Max/6 = One Sixth of the maximum amount. 

 

Corner Notch for Splitters 

If the software is used to generate splitters on some rectangular fittings, this option allows the user 

apply a notch to the corners. From the drop-down menu select a notch from the list available. These 

notches are pre-set in the Pattern Database.  

 

Reflex Connector Angles 

These allow connector ends to be marked with a slit or a marker notch if the angle between the 

sides exceeds 180 degrees. The choices are Slit or Mark, check the desired option. 
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Double Skin 

Although the Double Skin option is still available it has been superseded by the Double Wall option, 

which is available during Pattern Takeoff. For a more information about Double Wall see the Double 

Wall section of the On-Line Help. 

 

Insulation 

This option allows the user to configure the way insulation is applied to patterns. This option is set 

up here, but each pattern needs to be individually customised to use this option. 

 

 
 

If the Insulation type is selected as Inside, then the settings within the Inside section will be used.  

The Thickness field allows the user to choose whether an amount equal to the Insulation thickness is 

added or removed from Male and Female seams. There is also an Ignore option.  

Alternatively an amount entered in the Adjust field will add or remove a specified amount.  

The Outside section works in the same way as the Inside section.  

The Super measure tick box will add Pi x Insulation Thickness to each side of the insulation 

development to allow enough material at the outside edge of the Insulation. Will only work on 

outside insulation.  
 
Areas Covered 

Round Developments. 

Alternate Throat Seams. 

Default Connectors. 

Hole Castellation and Stitching. 

Clip Holes. 

Fixing Holes. 

Pattern 866. 

Default Notching. 

Insulation options. 

 

Completed q 
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Section 6: Item Take Off 

 

Aim 

 

To show how to customise and use the Views available in the Takeoff screen 

 

Details 

 

The Pattern Takeoff window is used to set the pattern template values and then accept the pattern 

into the Job. This is accomplished using the four pages or tabs: Dimensions, Options, Items and 

Connectors. The values set here are the values used to generate the pattern developments and 

therefore the subsequent NC code. 

 

 
 
The Pattern Takeoff window is split into two sections. The Pattern View section on the left is divided 

into four views, showing the pattern from different perspectives. The Data Input section to the right 

is where the pattern data is entered. There are always four buttons at the bottom of the window, 

these are used to Develop, Redraw, Cancel and Accept the pattern respectively.  Some patterns 

however, will have a fifth button called Holes.  This is used to set holes and slots in the item during 

takeoff.  If the pattern does not support the use of Holes then the button will not appear.  Clicking 

on the Holes button will cause extra fields to appear in the Dimensions tab of the pattern. These are 

explained further in this topic. 

 

6.1 The Pattern View Section 

The four views of the pattern represent the Front Elevation, the Right Elevation, the Plan and the 

Isometric view, based on the default First Angle Projection. The Isometric view can also be rotated 

manually to enable the user to get different views of the fitting. 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 79 of 166 

 

 

Click and hold the left mouse button anywhere in the bottom right window and move the mouse in 

the desired direction to rotate the View. If Third Angle Projection is preferred, the user can switch 

the views. 

 

Right click on the top right and bottom left windows, and select Properties, the Viewing Options 

window will appear.  

 

 
 

Ticking the Mirror View box and OK. The Pattern View section will alter to reflect the changes. 

Note that the top right and bottom left views have been reversed.  The four views serve two 

purposes. They give an impression of what the fitting will look like when cut and fully formed, and 

they also act as a guide for determining what particular dimensions in the Dims list refer to.  Click 

Redraw or press F7 at any time to update the four views to reflect changes made in the Data Input 

section.  

 

Click on the Develop button to bring up a view of the parts in their two-dimensional profiled form. 

As below.  
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This Development view allows the user to cycle through the separate developments of the fitting. 

The view will display the original extents of the pattern (black) and any allowances that have been 

added on (light blue).  Development lines (green) and inner cuts (red) where applicable are also 

displayed.   

 

• The identifiers for connectors and seams are also shown (Cx / Sx).  

• The X Size and Y Size fields display the blank size of the development.  

• The Area field displays, in mm/sq the actual area of the developed part.  

• The Part field displays the amount of developed parts within the fitting and which one is 

currently being viewed. It is possible to view all of the developments within a fitting by 

clicking on the Next and Previous buttons. Click End to return to the Pattern Takeoff screen.  

• The Material and Gauge fields display the selected material and gauge for the fitting.  

• Enabling the Not Cut option allows the user to disable the cutting of individual developments 

within a fitting.  

 

6.2 The Data Input Section 

The Data Input section allows the user to enter relevant dimensions and enter other important 

information. As an example of the variations possible from a single pattern, a Pipe with Branch (CID 

851) will be used. By changing the data in the input section, it is possible to redraw the fitting and 

see the changes as they affect the pattern. The lettering convention used throughout only applies if 

the pattern has no locked dimensions. 

 

Dimensions tab 

In this case, this case the Dimensions tab is displayed first. 

 

Enter the dimensions as requested. The example below shows the list of dimensions available. On 

the left hand side there is a list of letters, in this case A - K. When used in conjunction with the 

Pattern View section it is possible to relate each dimension to the fitting itself. In the images below 

is possible to see where the Pipe Diameter (A) will be applied, as is the case of all the dimensions.  
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It is also possible to see which Seams and Connectors have been applied to the fitting. In the 

images above this is denoted with the C1 and C2 entries for the Connectors and the S1 entry for the 

Seam  

 

If the pattern supports holes, a Hole button will become available.  Clicking on this will bring up a 

pull down box where it is determined on what face the hole will be applied. 6 extra fields will then 

be available at the bottom of the Dimensions tab.  These are:  

 

Hole Width #1 

This field will determine the diameter of the hole is it is circular, or the width of the whole if 

rectangular. 

 

Hole Depth #1 

There are 2 options in this field, Circular, which will use Hole Width #1 to determine the diameter, 

or Value, which will create the rectangular depth. 

 

Hole Radius #1 

There are 3 options in this field. Rectangular, Oval and Value.  These are used to determine the 

corners of the hole if cut as rectangular. This field has no effect if a circular hole has been cut. 

 

Inset #1 

This field can be Central or a Value.  This will inset the hole either centrally or by a set distance 

along the x axis. 

 

Offset #1 

This field can be Central or a Value. This will inset the hole either centrally or by a set distance along 

the y axis 

 

Collar #1 

This will apply a collar onto the hole. 

 

If more holes are added, more fields will become available but will be labelled Hole Width #2, Hole 

Width #3. etc.  

 

 

Options tab 

The Options tab allows the user to configure the available options specific to that pattern. The 

options tab will be relevant for each fitting and therefore contain different options.  

 

Item tab 

The Item tab enables the user to enter other important information. By default the Item tab will 

appear as shown on the next page. 
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The Item No field allows the user some identification for an inputted part. This can be either letters 

or numbers. If Auto-Increment item numbers has been selected in the Main Database – Item Entry 

then this field will be filled automatically. 

 

The Qty field sets the number of fittings to be manufactured.  

 

The Material and Gauge fields allow a specific material and gauge to be associated to the fitting. 

This is usually determined automatically by the Specification selected.  

 

The Notes field allows the user to enter notes to be attached to the fitting. These can either be 

typed in manually or selected from a pre-defined list in the drop-down menu.  

 

Selecting a Specification allows several factors to chosen automatically, these include the 

Material, Gauge, Seams, Connectors and others.  

 

It is also possible to enable more options on the Item tab. For more information see the 

Customise Takeoff section of the On-line help. 

 

Note: For further information see the Specifications section of this manual or the On-line help. 

 

Connectors tab 

The Connectors page allows connectors and seams to be assigned to the pattern after they have 

been set up in the Pattern Database. This method allows a common series of allowances to be 

applied to all connector ends of a pattern and for a seam to be identified by name rather than by the 

size of allowance. This is helpful in that printouts of the pattern will list the actual connectors and 

seams rather than a series of turnovers and allowances. If Specifications have been set up, it is 

possible that the seams and connectors will be selected automatically. Even if this is the case, it is 

still possible to change the seams and connectors to be applied. 
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The Connectors section at the top of the tab shows a list of the connectors available in the fittings. 

Once again, it is possible to relate which connector will be added and where. 

Click on the drop-down menu to select a different connector as required  

 

The Seams section, similarly to the connectors, shows a list of seams in the fitting. As before, it is 

possible to relate which seam will be applied and where. 

When the all Dimensions, options etc have been entered, it is possible to accept the part. 

Click Accept or press the End key to accept the part into the Job 

 
Areas Covered 

 
Takeoff Views 

Item Entry 

Customised Views 

 

Completed q 
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 Section 7: Quick Takeoff  

 

Quick Takeoff Views 

 

Aim 

 

To provide the user with an understanding of the various views available when using Quick Takeoff 

and how to customize these view to the users preferences. 

 

Details 

 

Quick Takeoff has been designed for speed purposes. It enables the user to takeoff items from an 

all-in-one viewing interface. All item information is contained within the one view allowing for easy 

access to changing properties and entering into the job. There are shortcut keys which the Quick 

Takeoff views have been designed for use with that enables further speed improvements when 

taking off items. These are mentioned further on within this section at 6.2 Quick Entry – Folders 

View. 

 

The view is fully customisable in which the user can determine exactly what is to be shown within 

their view. There are however various Quick Takeoff modes which are as described below: 

 

7.1 Normal Quick Takeoff view 

 

 
 

Within this view the window panes are arranged to provide a full screen view of the item 

information. The items can be selected from the left hand pane which then inserts the selected item 

on the right with a graphical representation and sections for dimension, connector, seam, item 

information and options. 
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To remove fields from this view you would need to Edit the pattern from within Item Folders. 

Locking dimensions from the Edit menu would then remove the dimensional input fields from this 

view – thus only displaying the fields that are unlocked. 

 

7.2 Quick Entry – Folders view 

 

  
 

This option when selected from the View menu provides the user with a tabbed list of all the 

dimensions / options that are required for that particular item. These fields are fully customisable if 

the user wanted to add / remove particular fields. 
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To add or remove fields from this view the user would have to click View > Customise from the main 

menu. Clicking the Quick Entry Information tab from this Customize Quick Takeoff window allows 

the user to set which dimensions appear and in which order. 

 

 
 

Please note that clicking the properties option when selecting Item Dimension List would result in 

you being able to setup which dimensions are displayed on screen. 

 

 
 

If the user selects List All Available Data option, this will display all dimensions that are unlocked 

on the item. This can be determined by Editing the item from Item Folders view and using the 

lock/unlock option for each dimension.  

 

If Display data for index # is selected and its given a value in the value field, this would display 

the number entered position in the dimensions list that is unlocked. I.e. the number ‘1’ would 

display the first dimension that is unlocked, ‘2’ the second and so on. 

 

Common Shortcuts for Quick Takeoff 

 

Tab: Moves the current highlighted field to the next available. 

Shift + Tab: Moves back to the previous field 

End: Adds the item selected to the job 

F1: Displays Help menu 

F3: Zooms in when using isometric view only – mouse would also require to be positioned on 

graphic 

F4: Zooms out when using isometric view only – mouse would also require to be positioned on 

graphic 

F7: Redraws the item 

F8: View developments for selected item 

F9: Opens the Creates New Section window 

F12: Defaults the window panes to their original state. 
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7.3 Quick Takeoff – Service Mode 

 

 
 

This view act in the same way as Quick Entry but the left displays the service menu with the option 

to select various services from the drop down menu. The user may require a Service Template 

setting up similar to the above where you can position their items on tabbed menus.  

 

The service menu is fully customisable and allows for conditional formatting of the buttons. This 

could be if you wanted an elbow bend icon that, depending on the size input, would determine 

whether pressed or segmented would be inserted and costed. Services and its advantages are fully 

detailed at Section 8 Service Templates. 

 

Areas Covered 

 

Quick Takeoff views 

Quick Takeoff Shortcut keys 

 

Completed q 
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 Section 8: Services  

 

8.1 Service Mode Overview 

 

Aim 

 

To familiarise the user with the service mode interface and create new customised service templates 

 

Details 

 

The service mode environment allows the user to customise the service buttons that are most 

commonly used, enabling quick access for inserting items into the estimate. 

 

Service templates allow the user to switch between service types via the drop down Service menu. 

This lists all the available services setup within the database. The service can be sorted into sections 

using a tabbed system. Button shortcuts are used on each of these tabs which relate to your items.  

 

 

 
8.2 Service Options Defined 

 

Creating a service can be achieved by File > Setup > Service Database or alternatively for quick 

access, clicking the Service link. 
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The main options that are used for creating or amending the service template will now be shown 

below: 

 

 Service: Drop down list which lists all available services setup 

within the database. 

 

 Print: Provides the option to print the current selected service or prompts to print all services 

within the database. 

 

 Service Information: Opens the Edit Service Template window which you can then edit the 

button that displays on your service menu. 

 

 New Service Type: Creates a new service. Clicking this option allows you to create a copy of 

the existing service in view if required. 

 

 Delete Service: Deletes the selected service 

 

Flow Direction: Allows you to set the Flow type to the service, this could be supply or extract for 

example. 

 

Default Shape: Allows you to specify the default shape of the service. 

 

Service Specification: Allows you to specify a specification to be used with the service. 

 

 

8.3 Editing Service Templates 

 

Aim 

 

The understanding of service templates and how they can be used within CAM-Duct 

 

Step by Step 

 

� Select the “Edit Service Database” icon from the service and sections toolbar. 

� Select the “General Supply”  service from the drop down menu 

� Select the “Service  Information” icon  
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� Observe how the “Ductwork - Keyboard” service uses a service template of Trace Estimating 

which contains various item buttons arranged into tabs. Note – The item buttons are 

shortcuts to the items contained within the folder structure on the left hand side 

� Select the “Use Service Template” drop down menu and select various service templates and 

observe how the different templates have different buttons associated with them. 

� Services using the same templates always have the same service items associated with 

them, item buttons can be deleted from the template by right clicking the button and 

selecting “Delete Button”. Note – deleting a button from a service template will affect all 

services using that template 
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� Service templates can have a specification applied to them which will result in any service 

using that template using the specification set. Note – The template specification will be 

overridden if a service specification is applied (see below)  
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Completed q 
 
 

8.4 Creating New Services 

 

Aim 

 

The ability to create new services and services templates 

 

Step by Step 

 

� Select the “Edit Services” icon from the service and sections toolbar 

� Select the “New service Type” icon ,when prompted if you want to create a copy of the 

current service click no 

� Input a Service Name of Dust Extract and select the Group as HVAC 

� Select the “New Template” icon  

� Rename untitled to Dust Extract 

� In the grey space below the template specification drop down menu right click and select 

“New Tab” (see below), when prompted input a description for the new tab enter 

“Rectangular” 

 

Service Specification Will 

Override Template Specification 
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� From the folder structure on the left hand side, expand the HVAC folder then select the sub 

folder “Rectangular” and drag and drop onto the button tab created 

� Create a new button tab called “Lindab Round” and drag the HVAC > Round > Lindab > Vent 

folder from the left hand menu onto the button tab 

� Create a new button tab called “In Line Equipment”, expand the folder HVAC > Equipment 

and drag the In Line folder onto the button tab 

� Create a new button tab called “End of Line Equipment”, expand the folder HVAC > 

Equipment and drag the End of Line folder onto the button tab 

� Click OK 

� Select the Company Name service from the services drop down menu and observe how the 

items have been arranged onto the different button tabs (see below) 

 

Completed q 
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8.5 Adding Conditions to Service Buttons 

 

Aim 
 
The ability to add conditions to service items to allow the attachment of different items depending 

on user defined criteria 

 

Step by Step 
 

� Select the “Edit Services” icon from the service and sections toolbar 

� Select the dust extract service from the service drop down menu then select the Service 

Information button 

� From the conditions field, right click and select “New Condition” 

 

 
 

� Name the new condition “Pressed <=250” 
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� Repeat creating a condition called “Segmented > 250” 

 

 
 

 
� From the Lindab button tab, delete the following buttons – B90 (Pressed Elbow) & BF90 

(Segmented Elbow) 

� Highlight the first condition set up “Less than Equal <=250” 

� From the item folders on the left hand side, locate the Lindab > Vent folder and drag the B90 

back onto the button tab 

� Highlight the second condition set up “Greater than >250” 

� From the item folders on the left hand side, locate the BF90 and drag and drop on top of the 

B90 button. 

� Right click the B90 button and select “Button Properties”, observe how the two items are now 

on the same button but with different conditions applied to them 
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� Click Ok on the “Edit Service Template” dialog box, then click OK on the “Setup Services” 

dialog box 

� Select the “Dust Extract" service from the service drop down menu 

� From the Lindab Round service tab in the service select the “Spiral Tube”, select a size of 

250 and insert into the drawing 

� Select the B90 

� Remove the attacher arrow from the B90 

� Select the “Spiral Tube”, select a size of 300 and insert into the drawing 

� Select the BF90 

� Observe how we  applied different elbows depending on the diameter of the spiral pipe 

 
 
 

 
 

 
 

 
 
 

 
 

 
 
 

 
 

 

Completed q 
 

250 Diameter pipe, condition applies B90 

300 Diameter pipe, condition applies BF90 
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 Section 9: Opus  

 

9.1 Editing a part in Opus 

 

Aim 

 

Provides the user with the ability to manually amend and manipulate the pattern development. 

 

Details 

 

Opus is the built-in drawing package that is custom designed for two dimensional profiled parts. 

Opus works in a similar way to most commercial CAD packages by allowing the user to construct 

their drawings using standard commands. 

 

There are a number of ways to access Opus, these are listed below. 

 

Click the Opus icon on the Item Folder Toolbar. If the Opus icon is not visible, it may be necessary 

to enable it. To do this, Click on Item Folders > View > Toolbars > Item Folder Toolbar.  

Alternatively right-click in the folder contents window of any Item Folder, and click New > Empty 

Opus Part or if already using Profiler click on View > Opus. 

 

 

From the Job Contents screen click the Opus icon on the Job Contents Items tab. If the Opus icon is 

not visible, it may be necessary to enable it. Click on View > Toolbars > Job Item Contents  

Alternatively click on File > New Job. In the Job Wizard, select the Item Folders tab and click the 

Create New Opus Part(s) and click Finish  

 

 

It is also possible to directly edit the developments of a pattern that has already been added to the 

Job Contents. Right click on an existing part and from the pop-up menu select Edit Developments  

The first development of the fitting will then be visible in Opus mode  
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There are three ways to select commands in Opus. 

 

The first is from the Opus Menu. This allows the user to select commands from a drop-down menu. 

Click on the Opus menu and the drop-down appears, select the relevant command from the list of 

available commands for Opus in Appendix A. 

 

Command Line 

The command line allows for commands, listed in Appendix A, to be typed directly, such as line, 

circle, etc. 

 

There are a number of keyboard and mouse shortcuts available, these are: 

F2 - Centre on Cursor. 

F3 - Zoom In. 

F4 - Zoom Out. 

F5 - Zoom Extents. 

F6 - Zoom Selected. 

Shift - @ switches between Absolute and Relative Mode. 

F8 or 'Ortho' at the command line toggles ortho mode on and off. 

Ctrl - Del is a shortcut deletion method. 

Length gives the true combined length of all selected elements. 

C will close a polyline. 

A selects all elements on the drawing. 

Mouse Shortcuts 

You can also use the Scroll Wheel on a mouse, along with keyboard keys, to perform specific 
functions within Opus. 

• When Zoomed in, using the Scroll Wheel, on its own, will move the screen up and down.  

• With the Shift key pressed, the Scroll Button will move the screen left and right.  

• With the Ctrl key pressed, the Scroll Wheel will zoom in and out of the screen  

Toolbar Icons 

This provides a shortcut method of accessing the most commonly used commands. 

 

Note: Although some commands are not accessible from the toolbars and the command line, all 

commands can be accessed from the Opus menu. The method of selecting a command has no effect 

on the commands functionality. 

 

 

Areas Covered 

Opening Opus 

Using Opus Commands to manipulate Developments 

 

 

 

 

 

 

 

 

 

 

 

Completed q 
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Section 10: 3D Viewer 

 

10.1 3D Viewer Settings 

 
Aim 

 

Provides an understanding of all the various global settings within the 3D Viewer environment 

 

Details 

 

The 3D Viewer Settings dialogue box can be accessed via the 3D Viewer Tool bar icon as shown here 

or from typing the command SETTINGS from within the viewer space. 

 

 

 

 

 

 

 

 

 

Here you are able to customize how the 3D Viewer operates and configure the options to suit your 

individual preferences for example Snap preferences, general viewing options, annotation text size 

and printing methods. 
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The defaults are pretty much set for effective use for the software but should they need to be 

changed for individual preference the above settings are all customizable. For example – if the user 

wanted a greater degree of turning when using design line – Snap Options – Polar Snap Angle would 

allow for this. 

 

Users are able to set a graduated background which provides a mixture of colour as the background 

in place of the ordinary white space. This can be useful to display imported underlay’s containing 
white lines that appear hidden at first glance. 

 

Completed q 
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10.2 Drawing Commands in CAD Mode 

 
Aim 

 

To provide an understanding on the drawing commands within the 3D viewer 

 

Details 

 

When using the commands that are listed below. It is always best practise to view what is displayed 

in the status area of the software. This is located towards the bottom left of your view when in the 

3D viewer. This helps you understand what is expected of you when running a command. 

 

 
 

Here is a breakdown of all the commands and a description as to what each one can achieve by 

selection. 

 

ADDTEXT: Prompts the user to add Free entry text within the 3D viewer. Users can specify the 

height of the text to be inserted once actual text has been confirmed. Text styles can also be 

applied to the text. 

 

ADDUNDERLAY: Prompts the user to import an underlay (DXF, DWF file types for example). This is 

identical to using the Right Click > Import Underlay option. 

 

ALLIGNSCALE: After importing an object, this command allows the user to specify the alignment 

and to what scale the object is to be re-adjusted to. 

 

BODTOD: Displays the geographical reference to the Top of Duct and the Bottom of Duct on the 

selected items. 

 
CALDUCT: Brings up the Duct Air Flow Calculator similar to the option on the toolbar. 

 

CHANNSZ: Allows the changing of your text size. You can set the value of your displayed text in 

the view. Selecting this command allows you to multiple select text within your drawing via dragging 

a selection window. You are then prompted with a value box to insert your new size. 

 

COPY: Copies the selected object(s) 

 

DELETE: Deletes the selected object(s) 

 

DIMA: Creates an alignment between two points. Selecting this option will allow for you to 

manually select points on your view that are required for measuring – hovering over objects will 

allow to snap to your desired point. You can then present dimensions on your tender drawing as 

shown below which do not necessarily need to be parallel: 
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DIMO: Creates the dimensions but in a parallel mode only for straights unlike the angled version 

when using the DIMA command. See below: 

 

 
 

DUCTSIZE: This command can be used to highlight on screen the dimensions of you duct. Selecting 

an item whilst within this command creates an annotation of the items end size. 

 

EDIT: Using this command allows for the editing of a selected object 

 

EDITCON: Shortcut to the Constraints Manager interface. 
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ENDRUN: Whilst in Design line mode and creating your run, using this command will end the run 

similar to a Right Click. 

 

FLY: Enters the Fly Mode similar to that on the toolbar. Using this command allows for the fly mode 

to be user controlled.  

 

• Left clicking and holding will determine the speed in which you navigate forward.  

• Right clicking and holding will determine the speed in which you zoom out backwards.  

• The direction of movement is determined by mouse movement. 

 

GOTOITEMS: Allows the user to select an item from within the viewer and this will change the view 

to the Job Contents screen with the selected item in view. Useful if using a fairly large drawing and 

you want to single out an item. 

 

HELP: This command brings up the Command List which includes commands that are available. 

 

ITEMPROP: This command will bring up the selected objects Item Properties window as shown 

below: 

 

 
 

This makes it effortless for accessing a particular item and its properties rather than searching for 

that specific item in Job Contents. Changes can be made in the normal way using this Properties 

window. 

 

JOINITEMS: Joins selected objects together. 

 

MOVE: Moves a selected item via a node. Using snap to node can allow the item to be snapped up 

against other items. 

 

NEWDESIGNOBJECT: Creates a New Design Line entry. 

 

ORBIT: Creates central pivot point for you then to orbit around the design using your mouse. 

 

REGEN: Regenerates all objects in view. Useful if changes have been made to the drawing and a 

refresh is required. 

 

REVDEDIGN: Creates a design line from a drawn and selected object and calculates width and 

depth in the process. Prompts for the selection of the item in which to create the design line from. 

 

ROTA: Enables you to select the object(s) and insert a value to be rotated by in degrees. Clicking 

on the object brings an input box to insert your value. 

 

ROTATE: Enables you to select a pivot point to then rotate your object(s). Again this can be used 

for multiple part rotation by selecting each object before using the command. This method of 

rotation will use the snap points to rotate the object(s) 

 

ROTATEATEND: Enables you to select the end of an object and insert a value for that object to be 

rotated by in degrees. Clicking on the end of the object brings an input box to insert your value. 
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ROTX: Rotate object(s) along the X axis. You can multiple select objects and rotate them all in one 

instance. 

 

ROTY: Rotate object(s) along the Y axis. You can multiple select objects and rotate them all in one 

instance. 

 

ROTZ: Rotate object(s) along the Z axis. You can multiple select objects and rotate them all 

together. 

 

SECNSIZE: Accesses the Section Flows dialogue box. 

 

SETATTACHER: Positions the arrow for where the next object will be placed and in which direction. 

Clicking on the ends of the object(s) allows the attacher to be placed and multiple clicking will 

position the direction. 

 

SETCONSTRAINT: Must be in Design Line mode for use of this command. Restores Design Line 

sizes and elevations so they can be drawn again and saves having to re-enter them. On running the 

command it prompts which line you want to copy the constraint for. 

 

 

SETELVATION: Sets the elevation of the selected object. This command when activated prompts 

you for the elevation height of the object 

 

SETTINGS: Opens up the 3d Viewer Settings window 

 

UNDO: If wanted to go back to a previous state the undo command will go back to an earlier time 

in your drawing.  

 

ZOOMTOFIT: Re-creates your view so your drawing fits within the on-screen 3d viewer window as 

a whole image. 

 

ZOOMTOWINDOW: Allows selecting an area of your drawing using two points with the mouse 

click. The software then magnifies the drawing and displays only the selected region in your view. 

 
 

Section 11: Nesting and Profiling  

11.1 Automatic Nesting 

 

Aim 

 

To provide an explanation of the Nesting windows and dialogues, and instruct the user on how to 

manually adjust a Nest. 

 

Details 

 

Automatic nesting is a major feature of the CAM-Duct software. This allows the user nest the parts 

in a job quickly and efficiently. The following topic illustrates some of the features and settings 

within Automatic Nesting. Once a job has been created and is ready to nest, click Utilities > 

Automatic Nesting or select the Automatic Nesting icon from the Utility Bar  

The Automatic Nesting dialogue box will appear. This has several tabs available for configuration, 

which are explained below.  

 

Note: The options set here are the same as the equivalent settings in the main database. If you 

change the settings here the main database settings will also change. The only exception to this rule 

is when using Automatic nesting through the Process menu. 
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General Nesting 

The General Nesting tab displays the values that were setup earlier in the Main Database – General 

Nesting.  

 

  
 

Autonest Options 

The options in this tab are the same ones that were configured in the Autonest Options section of 

the Main Database.  
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Preferences 

The Preferences tab allows users with more than one cutting machine to determine the preferred 

machine to nest to. This is necessary because the software can only nest a job in one way. A good 

example of this would be if a user had two cutting machines, one for Galvanised material the other 

for cutting Stainless Steel. When the user has entered the job, they would then decide which was 

the more appropriate machine to nest to. Depending on how the machine has been set up within 

installed machine, the nest can be affected in several ways.  It is always preferable to use the 

process system in environments with multiple machines. 

 

 
 

Nest for Machine 

This option allows the user to select, from the drop-down menu, the machine that will be preferred 

for nesting. If None is selected the default machine will be used.  

 

Across Width of Sheet 

This option will attempt to fill the width of the sheet before the length. This is generally the 

preferred method as parts can be lifted off the machine quicker as there is less area to fill before the 

torch moves down the table. 

 

Across Length of Sheet 

This option will fill the length before the width, essentially the opposite of the above option. 

 

Smallest Bounding Rectangle 

This option will attempt to use the smallest possible area, irrespective of its position on the sheet. 

 

 

 

Multi-Torch 

The Multi-Torch option allows the user to set the amount of heads available on their cutting 

machine. This allows for fast cutting of identical parts. This is mostly used on thicker material and 

machines with an OXY-Fuel torch. These are the same settings as the ones configured in the Multi-

Torch section of the Main Database  
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Method 

The Method tab will determine which nesting methods are applied. The options govern the general 

form of the nest. 

 

 
 

Batching 

The Batching allows the user to nest sections together or not. From the drop-down menu, select 

either None or Section. 

 

True - Shape Nesting (Default) 

Quick nesting is the most commonly used. It uses strips to nest the parts and this method is very 

accurate. It is the only type of nesting to utilise the settings on the Preferences tab and therefore is 

a necessity if part clearance is a factor. Quick nesting can be used to nest on remnant sheets. 

 

Row Nesting 

Row nesting is a good method for one-off symmetrical items. It is not as effective at nesting 

asymmetrical items. Row nesting cannot be used to nest on remnant sheets. 

 

Rectangular Nesting 

Rectangular nesting creates a minimum bounding rectangle around each part and no other part can 

encroach into this area. Therefore it is only a good method of nesting with rectangular shaped 

developments such as a multiple segment, segment bend sheet. The main advantage of this method 

is that it allows for zero margins between nested parts. This can be used to apply negative kerf 

values if required. This method cannot be used to nest on remnant sheets and the Try to Fill Gaps 

after main nesting switch will not apply. 

 

Edge Nesting 

Edge nesting will start from all four corners of the sheet and simultaneously work towards the 

centre. This can be used if considerations such as preserving the maximum remnant sheet are 

important. However it cannot be used to actually nest on remnant sheets itself. The Try to Fill Gaps 

after main nesting switch does not apply to this method. 
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Try to Fill Gaps after main nesting 

This switch will run further algorithms after the primary one in order to increase nesting efficiency. 

It will only apply to certain nesting methods as outlined above. 

 

Create Sheared Nests for Sheared Parts 

If parts are flagged as sheared, this switch will activate the sheared nesting function.  

 

Nest Insulation Developments 

This option will nest insulation developments, for machine cutting. 

 

Flanged Nests 

The Flanged Nest option has been specifically created for certain users. If more information is 

required contact MAP. 

 

 

 

Auto Stitching 

This option allows uses to automatically stitch nested parts to the criteria set. 

 

 
 

Automatically Stitch Nested Islands 

If this option is enabled the user is allowed to configured the following settings. If it is left un-ticked 

the following options will be unavailable. 

 

Outer Islands - If Long Side < 

This option allows the user to enter a value. If the long side of the part is less than the value 

entered, the part will be stitched. Alternatively select Any and the part will be stitched irrespective 

of size. 

 

Outer Islands - If Short Side < 

This works in the same way as the option above, but is applied to the short side of the part. 
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Inner Islands - If Long Side > 

This is the same as the same as Outer Islands - If Long Side < option, apart from the fact that is 

applied to the inner islands. 

 

Inner Islands - If Short Side > 

This works in the same way as the option above, but is applied to the short side of the inner island. 

 

Default Auto Stitching Values 

The options in this section set the length and quantity of the stitches that are to be applied. 

 

 

 

Sheet Order 

The Sheet Order tab determines the order which the sheets will be displayed within the nests tab 

within Job Contents section. When the NC data is written later, these settings will have a bearing on 

how the NC numbers are allocated. 

 

 
 

The image above determines that the sheets will sorted first by Material, then Gauge, then True 

Usage and finally by Sheet Insulation Flag. 

 

The order is determined by each fields position in the right hand pane. To alter order in which the 

sheets will be sorted, click on the Up or Down arrows on the right hand side.  

To add a new field to the right hand pane, locate the relevant field in the left hand pane and click it.  

Then click on the right pointing arrow to move it to the right hand pane. It can then be move up or 

down the sort order by using the up or down arrows as described above.  

The entire sort order can be reversed by using the sort direction icon.  
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11.2 Manual Nesting 

 

Manual nesting can be used to completely nest all parts or to adjust and modify a generated auto-

nest prior to writing NC. Manual nest gives the user total control over the way parts will be cut. It 

also contains functions that provide profiling options as applied to an entire sheet, rather than 

individual parts. After entering a job and it is ready to be nested, click Utilities > Manual Nest or 

select the Manual Nest icon from the Utility Bar.  

   

 

• A dialogue box will be displayed every time a new material and gauge combination is 

encountered.  

• Click Yes to add a new sheet for that particular material and gauge.  

• Note: If the General Nesting tab has been set to Use Default Sheets, an empty sheet will be 

added automatically, this will be the same size as the default sheet size set in File > Setup > 

Main Database > Materials or select the Main Database icon from the Utility Bar. If the 

General Nesting has been set to Prompt For New Sheet Size, the user will be able to select to 

sheet size to be used. 

 

 
 

The Manual Nest screen will now be visible. This screen is built around four main components. They 

are, Parts, Sheet Control Centre, Sheet Display and Menus & Shortcut Keys. They are described 

below. 

 

Parts 

The top section displays the parts that are to be nested on the material and gauge displayed in the 

sheet control centre (further details below). 
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The number in the top left corner of each part is the part number, the number below the part is the 

blank size (smallest bounding rectangle) and the blue number in the bottom right corner is the 

quantity of that particular part left to nest. 

 

Until the part has been nested on a sheet it will appear as below. 

 

   
 

When a part is nested onto the sheet, the display will change to reflect this. 

 

 
 

The quantity has been adjusted and a blue cross indicates that no more developments of this part 

are available to nest. 

 

Note: The instructions above are the default method. There is another option however. 

 

• Within Manual Nest, click View > Only Show Remaining Parts. Rather than placing a cross 

through the part, it will be removed from the Parts sections altogether, therefore only 

showing the remaining parts.  

It is also possible to right-click on any of the parts to display the following menu. 

 

 
 

Auto Quantity   

This option is only available on standard parts and profiled parts. It means that an unspecified 

quantity can be nested, therefore it is primarily used to fill up the remainder of a sheet. It is 

particularly useful when combined with the fill command explained below. 

 

Empty   

This option removes a part from the parts menu. This can be used if a development of a part is not 

needed. For example, if only the two cheeks of a square bend were required, the wrappers could be 

set to empty. 

 

Properties 

This option can be used to display the properties of the item from which the development 

originated. This is useful for identifying parts, and also gives access to graining options for a part. 

The part quantity can also be adjusted here. 
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Sheet Control Centre 

The sheet control centre can be either docked, or floating. It comprises of three main elements. 

 

 
 

The drop-down menu on the left displays the material and gauge currently being nested on.  

To change this, click on the drop-down menu and it will display all of the material and gauge 

combinations used in the job.  

 

The central drop-down menu displays all of the sheets created for a particular material and gauge 

combination. It displays the sheet size and the percentage of the sheet currently being used.  

To change the sheet being displayed, click on the drop-down menu and select a different sheet. The 

list of sheets will only be those relevant to the material and gauge selected above.  

 

The New icon will create a new sheet to the default sheet size. This sheet will be the same material 

and gauge as that selected above.  

The Properties icon can be used to modify the displayed sheet's size and can be used to set a 

multiple torch configuration for the displayed sheet only. Changes can only be made to a sheet if it 

is empty.  

Clicking the Delete icon will remove all parts currently nested on the displayed sheet. The sheet 

itself will not be deleted.  

The Delete icon will delete the displayed sheet from the job.  

Note: The Sheet Control Centre can be switched on and off, click View > Toolbars > Sheet Control 

Centre 

 

Sheet Display 

The largest section of the Manual Nesting screen displays a graphical representation of the sheet to 

be nested on. 

 

Manual Nesting - General Notes 

• Along the left hand and top edges rulers are visible. These can be used to see the size of 

sheet being worked on.  

• Parts with a yellow border are currently selected. The solid line border around the part shows 

the extents and also indicates that the part is placed on the sheet, therefore it can only be 

taken off the sheet again by pressing the Del key.  

• The dotted line shows the part extents plus the minimum margin between parts. This is 

determined in the General Nesting tab within the Main Database.   

• The dashed line will also indicate the rotation of the part, if the part is rotated in such a way 

that it no longer fits on the sheet.  

 

Placing parts on a sheet 

• To place a part on the sheet, left click on the relevant part in the Parts section at the top. 

The part will now be attached to the cursor.  

• Move the cursor down onto the sheet.  

• Place the mouse in roughly the correct place and left click to place a part.  

• Note: There must be a solid yellow line around the part for it to fit. 

• To rotate a part, click and hold the right mouse button and move the mouse in a circular 

motion. As a default the snap angle of rotation is set to 15 degrees.  

• To modify this angle, click Operation > Tool Options, and the following dialogue box will 

appear. This allows the user to enter a value to define the default snap angle when rotating.  

 

Note: It is also possible to override this setting. Hold the Ctrl key whilst rotating the part to snap to 

90 degrees, or hold the Shift key to snap to 1 degree. 

 

Move and rotate operations can be combined to enable the user to roughly position the part and 

then rotate it into alignment. To do this, hold both buttons simultaneously and then when the part is 

rotated, release the right button only, thus still retaining control of the positioning of the part. 
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Menus and Shortcut Keys 

There are several menus that are relevant to Manual Nesting only; they are Selection, Operation, 

Tools, Sheet and View. They are explained below. 

 

Selection Menu 

The selection menu is used to perform certain operations that can also be accessed using the 

keyboard. The keyboard shortcuts are listed next to the function name. Cut, Copy and Paste can be 

used in the standard Windows manner. 

 

-Nudge / Undo Nudge 

If the Nudge option is selected, the user is offered the Up, Down, Left and Right. These are used to 

move parts on a sheet as far as possible in a particular direction. The keyboard arrow keys also 

perform this function. It is useful for ensuring that parts are nested as close as possible to each 

other. Undo Nudge can be used to undo the last nudge performed. 

 

-Fill Sheet   

This option is used to place multiple instances of the same part into a nest without having to drag 

them down from the Parts section independently. When Fill Sheet is selected the user is again 

offered the Up, Down, Left and Right choices.  The fill will go as far as possible in a direction and fills 

can be combined to quickly fill a sheet. The keyboard arrows combined with the Ctrl key perform the 

same function. Note: The Fill Sheet option will only use the amount of parts associated with the 

selected item. 

 

-Mirror   

This option will flip a part over. This must be used with caution as the flipped part will be cut with its 

outer and inner sides reversed when compared to other parts on the sheet. The Tab key will perform 

the function also. 

 

-Select All, Deselect All and Invert Selection 

These options govern which parts are being manipulated. Selected parts will appear in Yellow. 

 

-Delete 

The Delete option will remove all of the highlighted or selected items. 

 

Operation Menu 

The Operation menu allows the user to access the manual nest modes. The following explains each 

of the available options. 

 

-Select 

• Click Operation > Select, or click on the Select icon  

This option allows for parts to be selected or de-selected by left clicking on them, without having to 

use the Ctrl key. It also allows the user to right-click on a nested part to show the parent item's 

Properties. While Select is activated, parts on a nest cannot be moved. 

 

-Edit  

• Click Operation > Edit, or click on the Edit icon   

This  is the default mode, all operations connected with moving parts, placing parts, flipping parts 

etc. are performed while in Edit mode. 

 

-Simple Cut Order   

• Click Operation > Simple Cut Order, or select the Simple Cut Order icon   

This enables the cut order for the sheet to be altered on a part-by-part basis. To use this option; 

• Left click on the green squares in the order of the parts to be cut. If the cut order needs to 

be determined from an existing number onwards, right-click on the number to be the next 

assigned. This will activate that number as the current one. For example, if 1 - 4 were in the 

correct order but 5, 6 and 7 needed modifying, right-click the existing number 5, which turns 

that number yellow, then left click the new number 5 to reassign. Further left clicks will 

assign 6 and 7.  
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-Advanced Cut Order  

• Click Operation > Advanced Cut Order, or click on the Advanced Cut Order icon      

This allows the cut order for the sheet to be altered on a cut-by-cut basis. Each individual cut has a 

separate number which can be reassigned using the method detailed above. 

 

-Chain Cut  

• Click Operation > Chain Cut, or select the Chain Cut icon    

This mode enables enables parts to be cut in one continuous torch activation, the purpose of which 

is to minimise pierce points. To place a chain cut; 

• Click and drag from one island to another.  

 

Chained cuts will, in general, only cut around half of one part before moving on to the next. The cut 

will return to finish the part after cutting any parts that are chained to it. The system will try to 

calculate the optimum cut path based on lead positions and on the parts that are chained or bridged 

together.  Note: The Lead In styles for chain cuts can be set up in the Tool options within Manual 

Nesting Further details can be found later in this topic. 

 

-Bridge Cut  

• Click Operation > Bridge Cut, or select the Bridge Cut icon   

 

Similarly to the chain cut option, this also allows for parts to be cut with continuous torch activation. 

A bridge cut will cut an entire part before cutting a path to the next part. This characteristic of 

bridge cuts means that only two parts can be bridged together. To connect more than two parts, a 

chain cut is used. The main purpose of bridging is that it can be used to terminate the end of a 

chained run so that the cut can turn around. 

 

Placing bridge cuts works in exactly the same way as chain cuts. Once placed, both can be modified 

by right- clicking on the small yellow start/end square. 

 

-Leadins   

• Click Operation > Leadins, or click on the Lead-ins icon   

This option allows for leads on the nested parts to be re-positioned. 
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The grey circle indicates the current lead position. To move a lead-in; 

 

• Left click and hold the mouse on a lead-in.  

• Then drag this around the island and the circle will snap to valid positions. On some parts it 

may only snap to the four corners of a rectangle, for example. This is because the NC code 

that will be generated will treat each of those four sides as a single instruction, therefore only 

the corners will be valid lead positions.  

 

Moving the mouse over the lead will display the cut direction indicator (blue) and the alternate cut 

path indicator (black). It is possible to alter the direction that the part will be cut. 

 

• Move the mouse over the alternate cut path indicator (highlighting the lead in yellow), and 

left click, the cut direction can be changed.  

 

It is also possible to view and change the lead style applied; 

 

• Right click on the lead position and click Properties to display the Leads dialogue box.  

 

 

-Stitching  

• Click Operation > Stitching, or click on the Stitching icon   

This option can be used to stitch parts to the sheet on a part by part basis. To perform this 

operation; 

 

• Click and drag a selection box around parts to be auto stitched, then right click to display the 

dialogue box below.  

 

 
 

• The Stitch Gap field sets the length of the stitch.  

• In the Number of Stitches field, enter the number of stitches required.   

• If Stitch at Start / End of Island(s) is ticked, the cut will leave a gap between the lead in and 

lead out with the same length as the stitch length value.  

   

 

Stitches are shown by black dashes around the island. 

 

It is also possible to manually stitch any part. To set the length of these stitches; 

• Click Operation > Tool Options and alter the stitch values there and then click OK  

 

• To apply the stitches manually, click Operations > Stitching and left click where the stitch 

needs to be.  

 

 

-Sheet Cut Rail 

This option allows the user to place a cut along the rail axis of the machine, select this option.  

• Click Operation > Sheet Cut Rail, or click on the  Sheet Cut Rail icon   

• Then click in the desired position on the sheet.  

• To adjust the position, move the cursor over the cut and a white square will appear, left click 

and hold the mouse, then drag the cut line to the new position.  
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-Sheet Cut Beam 

This option works in the same way as the option above, but in the Beam Axis 

• Click Operation > Sheet Cut Beam, or click on the Sheet Cut Beam icon   

 

 

-Zoom  

This option activates the mouse zoom mode. 

• Click Operation > Zoom, or select the Zoom icon   

• Left click to zoom in on the cursor position, right-click to zoom out or click and drag a box to 

zoom on the selected area.  

 

-Ruler 

The ruler is a rough guide to distances on the sheet. 

• Click Operation > Ruler, or click on the Ruler icon   

• Then click and hold the mouse button to measure between two points. This method of 

measuring is not accurate in that no definite points can be designated to measure either to 

or from.  

 

-Tool Options 

The options available here will depend on which mode the operations menu is in. For example, if the 

Bridge or Chain Cutting is selected, the tool options will allow the user to set the lead in style. If 

Stitching is selected, the tool options will allow the user to set the length of the stitches. 

 

Tools Menu 

The Tools menu offers the user further options. 

 

-Select Machine for NC 

This option is used to determine which machine to be used when writing the NC code. The * symbol 

indicates that this is the default machine. 

• Click Tools > Select Machine for NC and the following dialogue box will appear.  

   

 
 

If the Re-Apply Automatic Marking Text Now option is selected, it will re-orientate any marking on 

parts to fit correctly and be consistent throughout all the parts.  

Selecting the Re-Order Nest for this Machine Now will modify the cut order to the optimum 

configuration based on Start / Park / Home points. User Info is used to configure certain machine 

specific parameters such as Amperage (only available on a few machines).  

 

View 

The View menu can be used to toggle On/Off display dialogues within manual nesting. It also 

contains the zoom menu. Zoom commands can also be activated using F3 (Zoom In), F4 (Zoom 

Out), and F5 (Zoom Extents). 
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Areas Covered 

Manual Nesting 

 

Completed q 
 

11.3 Profiler 

 

Aim 

 

To provide an explanation of the Profiler windows and dialogues, and instruct the user on how to use 

the program to adjust the qualities of a part imported or created by Opus. 

 

Detail 

 

Profiler is the Module in CAM-Duct which pre-processes imported CAD Drawn Parts. These can be,  

 

• DXF Files or Parts of Nests.  

• NC Data Files written by other Software.  

• Parts drawn in earlier versions of CAM-Duct.  

 

The settings in Profiler are configured in the Profile Database. Profiler perform the following tasks,  

 

• Analyses the Geometry.  

• Removes duplicate Elements.  

• Reports or eliminates Gaps that are repairable.  

• Reports multiple Paths.  

• Orders the Parts into Islands : Inner, Centre Line and Outer.  

• Assigns default Lead-In's and Lead-Out's.  

• Assigns the default Tool.  

• Assigns colours to Islands and Tools.  

• Saves the Part with a Status Flag.  

 

Profiler can be accessed when importing an Item or through Opus by clicking on View > Profile. 

 

The following topics are covered within this section 

 

• Tool Use and Lead  

• Tools  

• Cut Order  

• Trim Marking  

• Check  

• Define Islands  

• Auto Repair  

• Stitch  

• Explode  

• Slice  

• Simplify  

• Common Line Array  

• DXF Export  

• Write NC 

 

Tool Use and Lead 

A simple part is defined as having a single Outer island within which there could be multiple Inner 

and Centre Cut islands. The outer most continuous island will be assigned as an Outer. All 

continuous islands contained within the outer will be assigned as Inner islands. Islands that are not 

detected as being continuous (intentional or not) are assigned as Centre Cut islands.  

 

If any continuous islands completely contain further levels of islands, these will be alternatively 

assigned Outer, Inner.  
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If any island is not contained within another island it will be assigned as an outer island.  

If a Centre Cut Island protrudes beyond the boundaries of the Outer Island, the Part will be 

contained in an artificial box for nesting purposes. A red box will be drawn around the Part Icon and 

the Status "O" for Outer Missing assigned.  

You are permitted to change the cut side on any island.  If you left-click on the outer island, the 

Tool Use dialogue box will be shown.  

 

 
 

By clicking on the down-arrow next to the Cut Side field, you can choose to make an island as 

Outer, Inner or Central as required. As you make a change, note that the leads may also change, as 

below. 
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The colour of the island will change as the cut side changes, Outer cuts being shown by default as 

blue, Inner in red and Central in purple, as shown below: 
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After importing a part, this mode is entered provided the part does not require repair. 

 

All of the Islands should have been defined and the colours should confirm all of the Inner, Outer or 

Centre Cut Islands. Small yellow circles indicate where the default Lead-In's and Lead-Outs have 

been placed. To confirm the Tool, Cut Type and Lead-In details for any Island, click with the Left 

Mouse Button on any element included in the Island. The Island will be drawn in the Selected Colour 

(default being yellow). 

 

The Tool Use Dialogue Box will be displayed. 
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-Tool  

Displays the default Tool as assigned by the setting in the database, File > Setup > Profile Database 

> Tool Defaults. If other Tools are available they can be assigned here on an Island basis. 

 

-Cut Side  

The Cut Side is important because it determines which side of the cut the tool thickness (kerf) will 

be applied to. 

 

-Kerf 

Relates to the thickness of the torch and can be set to Kerf Left, Kerf Right or Kerf Off. 

 

-Leads  

Displays the default Lead values. 

 

-Lead Style  

Click here to change the Lead Style. Lead Style Names and values are User defined in File > Setup 

> Profile Database > Leads. 

 

Each Lead Style defines : 

• Lead In Type :- None, Perpendicular, Straight, angled, Semi Circle  

• Lead In Size :- length required  

• Lead Out Type :- None, Perpendicular, Straight, angled, Semi Circle  

• Lead Out Size :- length required  

• Over burn :- length required. 

 

-Corner Styles 

Stop start, Clover Leaf and Triangular corner styles can be set-up if required. If Profiler detects 

Geometry restrictions, semi-circle Leads may be replaced by angled Leads. Profiler tries to detect 

any Leads that have been applied in the CAD Program. The values detected will be assigned to the 

Lead Sizes.  

 

Using the Tools Use and Lead-In Menu 

 

• The Cursor is displayed as a Pointer when moving over the Part.   

• Click on the required Island to confirm or change the Tool applied, the Cut Side or Lead 

In/Out values.  

• You must press Apply to activate the changes.  

• To Hide the Tool Use Dialogue Box right click outside it or choose another Menu option.  

 

Multiple Island selection 

 

• Hold the Left Mouse Button down and drag a Window around the required Islands. 

Alternatively hold the Shift Key down and click the required Islands to select.  

• Make changes in the displayed Tool Use Dialogue Box.   

• Click Apply to activate.  

 

Changing the Lead values and moving the Leads 

 

• As you move over a Lead-In position, as identified with a small red circle, the Cursor changes 

to four arrows.  

• Right-click to verify or change values.   

• A Graphic display help you to see the Leads and any Over burn.  

• Click the Left Mouse Button to drag the Lead-In to a new position on the Island.  

• Centre Cut Islands will only allow the Leads to be applied to the ends of the Island. 

 

 

Completed q 
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Tools 

This is used to apply a tool to specific elements within an island - e.g. to set one side of a 

rectangular part to null tool so that the part can be cut at the edge of a sheet. To access these 

settings click on Profiler > Tools.   

 

 
 

• Select the elements that you want to assign the tool to with the left mouse button.  

• When all elements required are selected, right click.  

• The Element Tool Use box will appear and the required tool and kerf can be set from here. 

 

 

Completed q 
 

Cut Order 

Displays the cut order for confirmation or editing. To access this screen click on Profiler > Cut Order. 
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The Cut order is displayed in a Green Box. The Cursor is represented by "+1,2". As the Cursor is 

moved over an Island Lead In, the Cut Order Box is highlighted in Red. If you wish to re-order the 

Islands starting from "1";  

 

• Click over the required Lead In position.   

• The "1" will be surrounded by a white Box.  

• Move to each Island in turn and click  

• Inner and Centre Line Islands should be processed before the Outer Island.  

• If you make a mistake, or only need to re-order from a particular Island, Click on the Island 

"Cut No", that you wish the new sequence to start from, with a right-click.  

• All of the Islands up to this Number will be highlighted in white. Higher numbers will be 

highlighted in Green.  

• Click on the next Island required in the sequence.  

• If using multiple Tools it is recommended that all Islands processed by the same Tool are 

kept together.  

   

Completed q 
 

Trim Marking 

Trim Marking is used to trim marked lines which extend beyond the cut outline of parts. Typically 

this can happen after importing a DXF file containing a number of parts. This will fix the error by 

showing the message, 

 

"This part is NOT ENCLOSED by outer islands!" 

 

Completed q 
 

Check 

Check examines the part for errors. If any are found, a dialogue box appears warning the user. 

 

 
 

To access the check function Click on Profiler > Check. The most common errors returned by the 

check function are: 

 

Overlying Elements 

Two elements are placed one on top of the other somewhere in the drawing.  

 

Intersections 

There are points on the drawing where several lines cross.  

 

This part is NOT ENCLOSED by outer islands!  

One or more of the islands are incomplete.  
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Auto Repair 

Attempts to fix any problems on the part using the parameters specified in File > Setup > Profile 

Database > Profiler Options. When a part has been checked and validated, any errors within the 

part will be highlighted with a red border and there will be a number of icons explaining the nature 

of the problem in the bottom left hand corner as shown below. 

  

 
 

A description and example of the icons displayed can be found below below. 

 

  
The part contains gaps smaller than the Profile Deliberate Gap Size, which have not been, or could 

not be, repaired. 

 

  
The part contains intersection, either because different elements intersect, or because leads of inner 

islands cut the island to which they are attached. 

 

  
This error is generated when the outermost island is not set to cut outer. This is essential for true 

shape nesting. 

 

  
Not likely to occur unless profiled parts are copied from another system, or tools are deleted from 

the machine setup. This warns that the part is using tools that cannot be located in the Installed 

Machines Database. 

 

 
The part does not contain elements that can be processed (lines, arcs, circles, text).  

 

 
Profiler was unable, to automatically sort the elements into islands, because of  multiple possible 

paths. Usually because three or more elements start / end at the same point . 

 

 
The part contains similar elements at the same position. This error is usually only seen if auto repair 

is disabled. 

 

 
This error is generated if the part contains outer islands which are cut before any inner islands 

which they enclose. 

 

 
The part contains elements which overlay or nearly overlay each other for significant portions of 

their length e.g. elements in tight v notches 

 

Completed q 
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Stitch  

The stitch command is used to leave small gaps of metal around the cut so that the part remains 

attached to the sheet. There are 3 options available in stitching. These can be accessed by clicking 

on Profiler > Stitch and selecting one of the following.  

 

Stitch Island  

 

• You will be prompted in the command line to Select Islands that you wish to have stitching 

applied to. 

• Click on the islands to highlight them (default colour is yellow). 

• Right click the mouse button to complete the selection process.  

• The command line will prompt for a Stitch Gap. 

• Type in the figure you wish the size of the stitch to be and press Enter. 

• The command prompt will ask for the Number of Stitches required in the part. 

• Type in the required figure and press Enter. 

• The command line prompt will ask for Open Ends, this requires a y/n response to determine 

where the cut will start. 

• With y selected the cut will start at the stitch as in Fig 1.  

• With n selected the cut will start with a "lead in" as in Fig 2.  

 

Fig 1 

 

 
 

Fig 2 

 

 
 

  

Manual Stitch 

This requests a stitch length and then allows you to give co-ordinates for the stitches to be placed at 

the command line, or click on the island(s) at the position where you want the stitches to be placed. 
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Remove Stitch 

Removes the stitches from the selected island, again by either entering co-ordinates for the stitches 

or clicking on the stitches that are shown on an island or islands. 

 

Completed q 
 

Explode 

In profiler once a part has been imported, if it consists of more than one item it may be exploded. 

This separates the various components so that they may be cut out individually.  

• To access this feature click on > Profiler > Explode. 

 

 
 

In the example above the profiled part consists of multiple items. Selecting explode from profiler will 

split up these items so that they may be nested separately.  

 

 
 

Clicking on Next will cycle through the parts individually. 

 

Completed q 
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Slice 

The slice command allows for manual oversize splitting of parts. Click on Profiler > Slice and a new 

menu will be available from which all slice commands are available and a new toolbar will appear. 

  

  

  

Polyline  

This mode draws lines in the same manner as the line command in Opus. Snap Modes can be used 

to pick points. 

Select  

This mode is used to select slice lines and adjust their position on the part. The lines drawn are the 

positions of the desired slices through the part. After the lines are in place, click to slice 

New Vertical Slicer  

This command attaches a vertical line running the length of the part to the cursor, which can then 

be moved or snapped into position. Click to fix the line.  

New Horizontal Slicer  

This command attaches a horizontal line running the width of the part to the cursor, which can then 

be moved or snapped into position. Click to fix the line. 

Auto  

The ratio is used to determine the number of equally sized slices to cut when the Auto slice is used. 

By clicking on the drop-down menu, the value can be adjusted from 1:2 to 1:12.  

Horizontal  

Click to slice the part horizontally into the number of parts indicated by the ratio.  

Vertical  

Click to slice the part vertically into the number of parts indicated by the ratio. 

Angular  

Click to slice the part into the number of angular segments indicated by the ratio. It is only really 

useful with circular parts.  

Cancel  

Removes any slice lines that have been placed onto the part.  
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Go / Slice  

Executes the slice using the lines drawn onto the development.  

 

Layers  

  

This can be used to import slice lines from draw-only layers constructed in Opus. This is useful if 

several parts are to be sliced in the same manner, as the slice layers can be drawn as a separate 

drawing. This drawing can be imported into Opus using the Cut Out > Import command, and then 

used to slice the part. Layers have to be set up in the Profile Database before this option will 

function properly. Tick both boxes to use the layer as a slice template. 

 

Dialog 

 
 

Start / End Point / Angle 

Absolute points can be specified for the start / end points of the split or a start point and an angle 

can be given. The co-ordinates follow the standard X and Y annotation. The angle takes a line going 

to the right as zero degrees. 

 

Split Horizontal / Vertical 

This allows for a single split at either an absolute height or by a percentage of the overall height of 

the drawing to be made. This option is enabled by ticking either Horizontal or Vertical.  
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Set-up  

 

 
 

Use Oversize Seam 

Select the seam from the Oversize Seams Database to be used to join the part back together. 

 

Export Layer 

Slice lines drawn will be placed on this layer. 

 

Default Import Layer 

This sets the default layer that will be used when a Layer Slice is performed. 

 

Auto Import Slice Lines 

This will automatically display lines drawn on the Default Import Layer as slice lines when Slice 

mode is activated. 

 

Slice Line Offset Snap 

Enable 

When enabled, this will automatically move the slice line by either a distance or at an angle from the 

first point clicked. 

 

Linear / Angular 

Set the desired distance or angle for the offset. 

 

Completed q 
 

Simplify 

Simplify takes the drawing and reduces its level of complexity so that when the NC is written for it, 

there are less instructions to download to the cutting machine. It is particularly useful on drawings 

containing True Type Text and ellipses, and on scanned in drawings. Click on Profiler > Simplify, this 

dialogue box appears. 
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Tolerance High/Low 

This slider bar determines whether the simplify command uses High tolerance levels for a more 

accurate representation or you can choose Low to lower the tolerance levels. 

 

Shape Retention Fine/Curvey 

This slider bar determines whether the simplify command uses Fine shape retention levels for a 

more accurate representation of the part or you can choose Curvey to lower the shape retention 

levels. 

 

Apply Whole Part / Selected Islands 

This determines whether the whole drawing or just a selected region is simplified. 

 

Clicking on the Advanced button will open up the following dialogue. 

 

 
 

Inside / Central / Outside Tolerance 

These figures specify at what point lines are merged to form a single line, therefore the degree of 

simplicity is expressed here. 

 

Restrict Angles 

This sets the angle that two consecutive lines must fall between before they will be considered for 

merging into a single line. 

 

Completed q 
 

Common Line Array 

This is used to create an array of parts from a simple part, the parts in the array sharing common 

cut edges where possible. To access this option Click > Profiler > Common Line Array. This task 

requires 4 items of information. 

 

• Kerf 

The width of material removed by the cutting tool. (From the Old English coerf - groove). The 

default value is picked up from the Machine Set-up information for the tool and material  

• Number of Rows   

The number of horizontal repetitions of the part.  

• Number of Columns   

The number of vertical repetitions of the part  

• Mirror(m), Rotate(r), Copy(c)   

Specifies the handling of alternate horizontal repetitions. If Mirror, the part is mirrored left-

right. If Rotate the part is rotated 180 degrees. If Mirror or Rotate are selected alternate 

rows are mirrored top-bottom  
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Completed q 
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DXF Export 

Within profiler it is possible to export the developments of a drawing as a DXF file so that it may be 

opened within other CAD packages. To do this, Click > Profiler > DXF Export. 

 

 
 

Save the drawing and it will be numbered according to the number of pieces. 

 

 
 

The part can be brought back into the program in sections by importing or can be imported into 

other CAD programmes. 

 

Write NC 

It is possible to write the NC data directly from within Profiler, to do this Click on Profiler > Write 

NC.  This will display the following dialogue box, prompting you for a number to assign the NC Data 

and a path to save it in. 

 

Completed q 
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Section 12: Reporting and Printing 

12.1 Default Reports 

 
Aim 

 
To provide an understating of reports and how to customize a report to suit requirements. 

 
Details 

 

Reports can be used for internal use and for external customer information. The CAM-Duct package 

has a wide variety of report already pre-configured for use. (Connector List, Delivery Note, etc) 

These reports are fully customisable in terms of what can be displayed. 

 

Reports are accessed via the File > Print Layout > Item Reports menu. This enables you to 

select the report wanting to be viewed and/or customised. 

 

Alternatively you can Print a desired report from the File > Print or Print Preview menu item. 

 

A typical Delivery Note report is shown below taken from a default installation. 

 

 
 
Items within the job can be sorted in any order to suit requirements. Customer information is placed 

within the header of these default reports taken from the Job Information entries that would have 

been entered at the early stages of the Job. (This being customer name and address etc). 

 
The logo can be changed to display your own company image in which the process is outlined 

below: 
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Step by Step 

 

• Access the Report via the File > Print Layout > Item Reports menu item. 

• Select the desired report for altering the header for. 

• Click the Header Layout option as shown below: 

 

 
 

• Right Click and select Properties on the Bitmap image display shown below: 

 

 
 

• Browse to your own image wanted to be displayed on the report. (BMP or PNG only 

supported file types.) 
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Completed q 
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Section 13: Downloading 

  
Aim 

 
Setting up and performing the Download of NC Data to the cutting machine. 

 
Details 

 

Unless the NC files are transported to the machine controller on a removable disk, a 

communications link must be established between the office computer and the machine controller. 

The link could be either fibre optics, conventional RS232 cable, or an RJ45. The diagram below 

shows a typical configuration for a RS232 cable link. 

 

 
 

The office computer is linked to the machine controller over a cable link. The cable/modem and the 

comms software together are often referred to as the DNC link. 
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Your operating system StartUp folder should contain the communications program which will 

monitor and process download requests from the machine controller operator. During normal 

operation the active comms program will appear on the desk top Tool Bar. 

 

Note: Comms programs are machine controller dependent and should be configured during 

installation. 

 

Areas Covered 

Communication Link to the Cutting Machine 

 

Completed q 
 

 

 

Section 14: Processes 

 

Aim 

 

Setting up and using automated processes to speed up the production of a Job 

 

Details 

 

When a job has been created within CAM-Duct it then has to be nested, NC has to written has to be 

written and reports printed. Whilst it is possible to do all of these individually, by setting up a 

process it is possible to perform all of these actions, or a combination of these. This section 

illustrates how this can be set up and used. 

 

14.1 Setting up a Process 

Click Utilities > Process > Setup and the Processes dialogue box will appear, or select the Setup 

Processes Icon from the Utility Bar. Note that all of the options in the lower section are 'greyed out'.  

 

 
 

• Click on the New icon.  

• A new Untitled process will be created and the options in the lower section will become 

active. 

• Rename the process from Untitled to something relevant, i.e. All In One. 
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Now it is possible to select which actions the process will perform. Generally speaking a process is 

set up to automatically nest, write NC and print reports. Each one of these option can be configured 

indivdually. 

 

 

 

• If automatic nesting is required in this process, enable the Automatically Nest Item(s) option. 

• Click on the Nesting Options button to set up the automatic nesting properties of the 

process. These are set up in the same way as the normal nesting options.  

• If the NC data is to be created using this option, enable the Write NC option. 

• Click on the Select Machine button and select the machine and options for the NC to be 

produced. 

 

 
 

• If reports are required from this process, enable the Print Reports option. Then click on the 

Select Reports button. 

• From the displayed list, select the reports that will always be printed, and the number of 

copies that are required when using this process, (please note that each report can have 

different numbers of copies),  and click OK 
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• Click Ok again and the process is now ready to use. 

 

14.2 Using the Process 

When the job has been set up by following the steps above and a all of the items have been added 

to a job. It is now possible to use the process. 

 

• Click Utilities > Process > Name of process. (In this case All In One) 

The actions set up within the process will now be performed, and a corresponded dialogue box will 

appear stating the process has been successfully completed. 

 

Areas Covered 

Automatic Nesting 

Write NC 

Reports 

 

Completed q 
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Appendix A: Opus Commands 

  

Select Mode 

The Select Mode option offers the user two choices Islands or Elements 

  

Islands 

Islands mode is for selecting and working with enclosed areas of the drawing that, when profiled, 

will probably be defined as a single cut and have a corresponding lead in / lead out. In this mode, 

clicking on any part of one of these islands will select the entire island. The command line will 

prompt Command: Select Islands when in this mode. 

 

Elements 

Elements mode is for selecting and working with single lines, arcs and simple shapes in a drawing; 

clicking on a side of a rectangle in this mode will only select that side (as opposed to the whole 

rectangle, which would be the case for Islands). The command line will prompt Command: Select 

Elements when in this mode. 

 

 

Nodes   

Insertion Points are used to create a known point on a part which can later be used for accurate 

positioning. The insertion point will act as the base point when adding shapes to an existing part. 

However, only one insertion point can exist. Insertion points are identified by a green cross with the 

annotation IP 

 

Click Opus > Nodes > Insertion Point > Create  

Enter the co-ordinates for the insertion point.  

Enter an offset (or just leave the values as zero if no offset is required), and press Enter  

 

To delete an insertion point click Opus > Nodes > Insertion Point > Delete  

 

Reference Points are used to create additional snap points. They are placed at, and can be offset 

to, any location. Reference points are identified by a green cross with Rx annotation, where x 

represents the reference point number. 

 

Click Opus > Nodes > Reference Points > Create  

Enter a set of co-ordinates for the point.  

Enter any required offset, or right-click to accept the default (no offset).  

Alternatively, Opus > Nodes > Reference Points > Create Fixed can be used to create a 

reference point that will not move with the island it is attached to. They are created in the same 

manner as regular reference points. 

 

To delete all reference points on a drawing click Opus > Nodes > Reference Points > Delete All 

 

 

Dimension 

The Dimension feature within Opus allows the measurements, or dimensions, of parts to be 

displayed alongside them. 

 

Click Opus > Dimension to access the dimensions submenu, and select one of the following options:  

 

Note: Clicking Opus > Dimension > Properties governs the appearance of the dimension lines. 

Therefore it is advisable to check these settings before positioning dimensions. 
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This dialogue box sets the dimension text height and width, and the width and style of the lines that 

act as pointers. Changes in here only affect dimensions that have not yet been placed on the 

drawing. 

 

Linear 

A linear dimension only takes either the x- or the y- axis (horizontal or vertical) into consideration. 

Even if the line is at an angle, only one axis can be measured at a time.  

 

To create a linear dimension: 

 

• Click Opus > Dimension > Linear  

• Click one end of the length to be measured.  

• Click the second end of the length to be measured. Move the dimension to the required 

position, and click to place it.  

 

Aligned 

This dimension is used to measure the true distance between two points on a drawing.  

 

To create an aligned dimension: 

 

• Click Opus > Dimension > Aligned  

• Click one end of the length to be measured.  

• Click the second end of the length to be measured. Move the dimension to the required 

position, and click to place it.  

 

Radial 

The radial dimension measures the radius of any arc selected. 

 

To place a radial dimension: 

 

• Click Opus > Dimension > Radial  

• Click on the arc to be measured.  

• Move the dimension to the required position, and click to place it.  

 

Angular 

The angular dimension will give the angle in degrees between the two selected elements in an 

anticlockwise direction.  
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To create an angular dimension: 

 

• Click Opus > Dimension > Angular  

• Click the first element. The angle will be measured moving anticlockwise from this element to 

the next.  

• Click the second element, moving anticlockwise.  

• Move the dimension to the required position, and click to place it.  

 

Label 

Places a text label on the screen, along with an array. 

 

To create a text label: 

 

• Click Opus > Dimension > Label  

• Click to position the bottom left hand corner of the area that will contain the label.  

• Click to position the top right hand corner of the area.  

• Type an angle (or accept the default if the text is not to be at an angle), and press Enter  

• Enter the actual text that will form the label and press Enter  

• Finally, click to position the arrow on the drawing.  

 

 

Scale 

The scale command allows for an entire drawing or part to be resized by a given factor.  

To scale a drawing or part: Click Opus > Scale and the following dialogue box will appear.  

 

  
 

 

Scale Factor 

These options determine how much the drawing should be scaled by. The first, Custom, will allow 

the scale to be specified either by entering a value in the scale factor box (immediately to the right 

of Metric To Imperial), or by entering values in the New Size boxes for width and height, 

respectively. 

Note: The ratio of width:height is conserved when entering values in these boxes, and so changing 

one affects the other. 

 

Metric to Imperial 

Scales the part by a factor of 0.0397 

 

Imperial to Metric 

Scales the part by a factor of 25.4 

 

 

Stretch 

The stretch command allows for one or more islands to be expanded along one or both axes. To 

stretch an element: 

• Click Opus > Stretch  
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• Click on all elements to be stretched  

• When all the elements are selected Right-click to finish the selection.  

• Opus will now prompt for the Base Point, which will be taken to be the fulcrum of the stretch. 

Click to position the Base Point, or enter a set of values.  

• Opus will prompt for the From Point. This is the point from which the selected element(s) will 

be stretched. Click to position the From Point, or enter a set of values.  

• Opus will prompt for the To Point. Click on the point the element(s) are to be stretched to, or 
enter a set of values.  

Note: If the user is working in Relative mode, the set of values entered will be relative to the base 
point selected earlier. 

 

New 

This incorporates the following Opus commands:  

- Lines  

The line command draws straight lines either between two given points, or at a given angle and 

distance from one point.  To draw a line between two points: 

• Click Opus > New > Lines or click on the Line icon   

• Click to place the first point, or enter a set of values.  

• Click to place the second point, or enter a set of values.   

Note: Opus will carry on allowing another line to be drawn from the previous point by prompting for 

more points to be entered. 

 

To finish drawing lines, click the right mouse button.  

To draw a line from a specified point by giving a distance and an angle: 

• Click Opus > New > Lines or click on the Line icon   

• Click once to place the first point on the screen, or enter a set of values.  

• Enter the distance of the line, followed by a less than sign (<), and the angle, for example: 

100<45, and press enter; or, if working in relative (toggled by using Shift+@) and ortho (F8) 

mode, simply point in a direction and type a distance. 

- Arcs  

The arc command draws arcs using three different points. There are five ways of creating arcs, 

which are described below 

 

3 Points 

The simplest type of arc. This prompts for three points and joins them with an arc.  

• Click Opus > New > Arcs > 3 Points or click on the 3 point arc icon   

• Click to place the first point, or enter a set of values.  

• Click to place the second point, or enter a set of values.  

• An indicator for the third point will now appear, tracing out the final path of the arc and 

following the movements of the mouse. 

• Click to place the final point, or enter a set of values.  

Note: Opus will now carry on prompting for second and third points to continue the arc in the same 

way. Right-click to finish drawing the arc.  

 

Start, Centre, End 

This method creates an arc allowing the user to specify the centre of the circle as the second point.  

• Click Opus > New > Arcs > Start, Centre, End.  

• Click to place the start of the arc, or enter a set of values.  

• Click to place the centre point, or enter a set of values.  

• An indicator for the third point will now appear, tracing out the final path of the arc with the 

movements of the mouse. Click to place the end of the arc, or enter a set of values.  

 

Start, End, Centre 

This method is similar to the previous method, but differs by prompting for both ends of the arc 

before the centre.  

• Click Opus > New > Arcs > Start, End, Centre  

• Click to place the start of the arc, or enter a set of values. 

• Click to place the end of the arc, or enter a set of values.  
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• An indicator for the centre of the arc will now appear, tracing out the final path of the arc 

with the movements of the mouse. Click to place the centre of the arc, or enter a radius for 

the arc.  

 

Centre, Start, End 

Similar again to the previous two methods, this will first request the centre point, and then the two 

end points of the arc.  

• Click Opus > New > Arcs > Centre, Start, End  

• Click to place the centre of the arc.  

• Click to place the start of the arc.  

• An indicator for the final arc will now appear, tracing out the final path of the arc with the 

movements of the mouse. Click to place the end of the arc, or enter an angle (to be rotated 

through anticlockwise).  

  

Continue 

Continue works in a similar way to the 3 point arc. It creates a new three point arc with the first 

point being the last point of the previous arc. Only the last point of the arc need be selected. 

• Click Opus > New > Arcs > Continue or click on the Continue arc icon to enable this arc. 

 

 

- Circles  

When using Opus, two very useful features are the ability to draw Circles and Ellipses. The 

instructions below illustrate how this is done. 

 

• Click Opus > New > Circles or click on the Circle icon   

• Enter a set of values, or click to position the centre of the circle.  

• Type in the radius of the circle or click to position the radius.  

• Opus will finally prompt for an offset value for the centre of the circle. Enter any required 

offset, or right-click to accept the default (no offset).  

 

- Rectangle  

When using Opus, it is very easy to draw rectangles, as the following instructions will demonstrate. 

 

• Click Opus > New > Rectangle, or click on the Rectangle icon   

• The command line now asks for the first corner of the rectangle, click a position or enter a 

set of values.  

• Enter the corner of the rectangle that is diagonally opposite to the first corner. This can be 

done by clicking on a point or entering a set of values. 

 

 

 

-Ellipse 

This command is similar in syntax to the circle command, but requires two separate radii values; 

one for each axis. 

 

• Click Opus > New > Ellipse or click on the Ellipse icon   

• Click once to position the centre of the circle, or enter a set of values.  

• Opus will then prompt for the major (usually longer) axis, and second for the minor axis, 

which will automatically be placed at right angles to the major axis.  

• Click once to position the major axis, then Click once to position the minor axis.  

• Finally, Opus will prompt for the number of component lines that the ellipse should be made 

of, right-click to accept the default, or enter a value. 

 

- Slotted Hole  

The Slotted hole command inserts a slotted hole into a part. 

 

• Click Opus > New > Slotted Hole or click on the Slotted Hole icon   

• At the Position (Relative) prompt, click on the point at which the centre of the slotted hole 

will be.  

• Enter the required Distance between centres value to define the length of the straight part of 

the hole.  
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• Type in the Slot Width to define the width of the slot.  

• Enter the Slot Angle to define the final position of the slotted hole.  

• Enter the Slotted Hole Offset  to define the width of the slot, type in a set of values or click 

on a point. 

 

- Slit 

The Slit command allows the user to insert a slit into an island. 

 

• Click Opus > New > Slit  

• At the Select Element prompt, click on one of the elements of the development. As in the 

image below.  

• At the Slit: First Point (Relative) prompt, click on the point on this selected element that you 

want the slit to begin from.  

• At the Slit: Second Point (Relative) prompt, click on the development to show where you 

want the slit to extend to, or enter a set of values to define the end location of the slit.  

• Click View > Profile to see the impact of the slit at an island level. 

 

- Perpendicular  

The Perpendicular command allows a perpendicular line to be drawn from a point to a selected 

object. 

 

• Open or draw a relevant part in Opus, the example uses a rectangle.  

• Click Opus > New > Perpendicular  

• At the prompt Select Element, click on the line from which the perpendicular line will be 

drawn.  

• At the prompt To Point either enter the relative co-ordinates, or click on the screen at the 

point where you want the perpendicular to be drawn. he perpendicular line will be shown at 

right angles from the selected element. 

 

-Notch 

Includes the following types of Notch: 

 

-Vee Notch 

The Vee Notch command allows the user to break a selected element and insert a vee notch 

anywhere along the selected element. 

 

• Open or draw a relevant part in Opus, in the example below a rectangle will be used.  

• Select Opus > New > Notch > Vee Notch  

• At the Select Element prompt, click on the line that will have the vee notch inserted.  

• At the Position (Relative) prompt, click on a point on the element where the notch will be.  

• Enter the required Depth of the notch.  

• Enter the required Width of the notch.  

• Click on the side of the element where the notch is to appear on the Select Side (Relative) 

prompt. The part will be redrawn with the notch inserted. 

 

-Sloping Notch 

The Sloping Vee Notch command allows the user to draw a vee notch based on points selected and 

width, with the chosen element being broken to accommodate the notch. 

 

• Draw or open a relevant part in Opus. In the example below, a rectangle is being used.  

• Click Opus > New > Notch > Sloping Vee Notch  

• At the Select Element prompt, click on the line that is to be broken.  

• At the First Point (Relative) prompt, click on the position on the line where the notch is 

required.  

• At the Second Point (Relative) prompt, click at the position where you want the notch to end.  

• Enter the Width of the required notch, and the part is redrawn with the notch inserted. 

 

-Tag 

The Tag command allows the user to insert a rectangular tag 

 

• In Opus, open or draw a relevant part.  
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• Click Opus > New > Notch > Tag  

• At the Select Element prompt, click on the element that you want to insert the tag into.  

• At the Centre Point (Relative) prompt, click on a point anywhere along the selected element. 

This will determine the centre point of the notch.  

• Enter the tag Depth and press Enter  

• Enter the tag Width and press Enter  

• Click on the side of the element where the tag is to appear at the Select Side (Relative) 

prompt and the tag will be inserted into the selected element 

 

-Junction Notch 

The Junction Notch command allows the user to insert a rectangular notch into a selected element. 

 

• In Opus, open or draw a part to insert the notch into. The example below uses a rectangle.  

• Click Opus > New > Notch > Junction Notch  

• At the First Element prompt, click on the first line to be notched.  

• At the Second Element prompt, click on an adjoining line for the junction.  

• Enter the Depth of the notch and press Enter  

• Enter the Width of the notch and press Enter  

• At the Select Side (Relative) prompt, click on the side that the notch is to be drawn. The 

notch will be drawn. 

 

-Rectangular Notch 

The Rectangular Notch command allows the user to insert a rectangular notch into a selected 

element. 

 

• In Opus, open or draw a part to insert the notch into. The example below uses a rectangle.  

• Click Opus > New > Notch > Rectangular Notch  

• At the First Element prompt, click on the first line to be notched.  

• At the Second Element prompt, click on an adjoining line for the junction.  

• Enter the Depth of the notch and press Enter  

• Enter the Width of the notch and press Enter and the notch will be drawn. 

 

-Insert 

Insert incorporates the following commands: 

 

-Import 

The import command allows the user to import pre-drawn shapes from an item folder. A good 

example of this would be an Access door hole. 

 

• Click Opus > Insert > Import and the Select Import Item dialogue box will appear.  

 

 

• Browse to and click the selected item and then click Open  

• The command line will now read Move: To Point.   

• The Move command will either be in Relative or Absolute mode, this can be toggled between 

them by using the Shift and @ keys.  

• Click at the point that will be the centre of the imported part when imported into the 

drawing.  

• Offset: Offset will now appear on the command line, enter a set of values or press Enter to 

accept the default value 0,0 and the part will not move. 

 

 

- Vectorized Images 

It is possible to bring a bitmap (bmp/png) image into the program by using the Raster to Vector 

import function. This tool will bring in the bitmap image and turn it into a Vector graphic that can be 

edited in Opus.  

 

• Open Opus and from the menus go to Opus > Insert > Vectorized Image.  

• This will open a dialogue box asking for the name and location of the image file to be 

imported. There are 2 types of image file format that can be imported, these are Bitmap 

(bmp) and PNG. 
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• Select the file to import and the Raster to Vector dialogue options will be displayed.  

  

There are a number of Presets included with the program but it is possible to create your own and 

save them as Presets. To change parameters of a Preset just make the changes needed, when the 

dialogue box closes it will prompt you to save the changes or create a new preset file.  

 

Trace Mode 

The Raster to Vector uses 2 different Trace Mode parameters for the imported image, you can select 

whether to use Centreline or Outline.  

 

For Outline the parameter "Minimum Pixel Length" enables you to eliminate outlines which length in 

pixels is less than the selected value.  

For Centrelines the parameter "Minimum Pixel Length" serves to eliminate artefacts.  It is used to 

remove centrelines which connect to another centreline only at one end and have a pixel length less 

than the selected value.  the side effect of a large value in this parameter may be in a loss of detail.  

There are three elements that can be chosen for recognition: Lines, Arcs, and Curves.  

 

Lines 

Detect Orthogonal (Horizontal and Vertical), and Detect 45 Degrees.  If, for instance, the 45 

Degrees option is selected then the special check will be done for lines if they can be identified as 

having 45 degrees inclination.  

 

Arcs 

Circles are included as arcs with equal ends.  No additional options available.  

 

Curves 

There are several additional options to choose from when Curves are selected.  

 

Curve Options 

Iteration Factor 

Smoothing is an important part in the curve enhancement mechanism.  At each iteration it re-

shapes the curve to make it smoother.  The number of Iterations defines the depth of the re-

shaping. Each iteration can slightly shift the curve, so one may trade accuracy against smoothness.  

When a high accuracy is required a few (1 to 2) iterations may be preferred. To create fine curves 

10 to 20 iterations may be an appropriate choice.  

 

Constrain Shift by Tolerance 

This will keep the curve on the black area for shift tolerance 0 or permit is 1 pixel close to black area 

for tolerance 1. The side effect of Constrain Shift by Tolerance is that it may affect smoothness so it 

is better not to use it when trying to obtain fine curves.  

 

Curve Representation 

There are 3 options for for representing Curves and are set in the selected by pull down dialogue.  

The three options are:  

 

Lines  

 

Polylines/Arcs 

When using this beziers are approximated by arcs and lines.  This transformation of beziers into arcs 

and lines is controlled by the parameter Poly Arc.  Larger tolerance gives less arcs.  

 

Splines 

Tolerance (Pixels) defines the precision with which bezier polynomials represent curves.  More 

tolerance produces less bezier points.  

 

Conjunction Tolerance is applied when one curve at it's end point is tangential to another curve at 

its inner point.  Less tolerance gives smoother conjugation but it can also shift the intersection.  

 

These are settings that do not depend on the type of element.  

 

Angle sensitivity: more sensitivity will mean that more angles are detected.  
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Intersect along Tangents: Controls the X-Type intersections. When unchecked a different 

simplified mechanism is used for lines to cross intersections.  May be reasonable to try in unchecked 

mode when poorly defined intersections are present like on a map with several families of 

intersecting lines.  

 

The Preview button will give a representation of what will be imported into the Opus program.  

Click OK to accept the imported image into Opus for Profiling or modification. 

 

 

- Cut Outs 

Cut outs allow for an island to be drawn inside another island, forming a hole. There are two default 

choices available, Circular and Square, along with the option to Import from a part existing in your 

Item Folders. 

 

• Click Opus > Insert > Cut Out and select either Round, Rectangular or Click Opus > Insert > 

Import  

• Selecting the Round option allows the user to place a Round cut out.  

• Click Opus > Insert > Cut Out > Circular and the following dialogue box will appear.  

• Enter a radius and click OK  

• The command line will now read Move : To Point. Click at the point that will be the centre of 

the circle.  

• Offset : Offset will now appear on the command line, enter a set of values or press Enter to 

accept the default value 0,0 and the circle will not move.  

 

In the same way as the Round option, this allows for a rectangle to be drawn, and is created in a 

similar way to the circular cut out. 

 

• Click Opus > Insert > Cut Out > Rectangular and the following dialogue box will appear.  

• In the Size field, enter the dimensions of the rectangle.  

• The Rotate field allows the user to rotate the rectangle, on its centre axis, by the amount 

entered here.  

• A Corner Radius can also be applied by entering an amount here.  

• Click OK  

• The command line will now read Move : To Point. Click at the point that will be the centre of 

the rectangle will be.  

• Offset : Offset will now appear on the command line, enter a set of values or press Enter to 

accept the default value 0,0 and the rectangle will not move.  

 

 

 

- Part Notes Text 

This gives the user the ability to add Notes to Opus Parts, which can then be displayed on specific 

printouts. 

 

• Open an existing Opus part and click Opus > Insert > Part Notes Text or click on the Notes 

icon   

• The command line will now read , Notes : Enter Text, type in the desired text, in this case 

Notes and press Enter  

• The command line will now read , Notes : Size Text, enter the height of the text, in this case 

50 and press Enter  

• The command line will now read , Notes : Size Text, enter the height of the text, in this case 

50 and press Enter  

• The notes will now be attached to the cursor, left click in the desired position for the text.  

• The command line will now read , Marking : Offset, enter a set of values or leave it set to 0,0 

to leave it where it is.  

• The word Notes will now appear on the part.  

 

Note: The Notes option is designed to display the text only and will not actually burn. 

 

- True Type Text 
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True type text can be inserted into a drawing, profiled and cut, any installed  windows font may be 

used. This option is especially useful for creating stencils. The profiler function, simplify, is 

recommended prior to to cutting. 

 

• Open an existing Opus part and click Opus > Insert > True Type Text or click on the True 

Type Text icon  and the following dialogue box will appear.  

• The Font Face sets the desired font to be used for the text. Any true type font installed on 

the computer will be available.  

• The Size field sets the height in mm's of the text.  

• The Italic option italicises the text.  

• The Orientation and Style options allow the user more configuration of text. Right To Left 

determines whether the text is written from right to left or left to right. If the box is 

unchecked, then the text will be from left to right. Vertical will display the text vertically 

rather than horizontally.  

• The Detail slide bar sets the number of lines from which the text will be composed. The 

greater the number of lines, the smoother the text will be but the more lines of NC data will 

be written.  

• The Weight slide bar determines the thickness of the text.  

• The Aspect Ratio slide bar determines the width of the text. The height set in the Size field 

will always be maintained.  

• The Enter Text field allows the user to type in the desired text.  

• The Checking For Intersections option will filter out any intersections points. This is 

recommended.  

• When all of these fields have been set accordingly, click OK  

• The True Type Text dialogue box will now close and the user will be returned to the existing 

opus part 

• The Text will now be attached to the cursor, left click in the desired position for the text.  

• The command line will now read, Offset: Offset, enter a set of values or leave it set to 0,0 to 

leave it where it is.  

• The text will now appear on the part. 

 

Note: The text added here is placed on the cutting layer and therefore will be cut out. 

 

- Marking / Printing Text 

The Marking/Printing option works in exactly the same way as the Notes option mentioned earlier in 

the topic. The only difference being that the Marking /Printing text will actually appear on the nested 

parts if the cutting machine has a marking tool. 

 

 

 

 

- Position Auto Text 

Auto text is used to provide a quick marking solution. To add the text, set the parameters for 

positioning and the text-specific options such as the angle of the text from horizontal and the size of 

the characters. When profiled, if a marking tool exists, the text will be marked on to the island. 

 

• Click Opus > Insert > Position Auto Text and the following dialogue box will appear.  

• Input the X & Y Positions, Height and Width Factor and click OK  

• The word AUTOTEXT will now be placed on the opus part.  

• The AUTOTEXT will pick up the Auto Marking settings defined in Installed Machine > Setup > 

Auto Marking Settings 

 

 

Modify 

The Modify command allows the user to modify Marking Text and notes, it will not allow the user to 

modify True type text. 

 

Move 

The Move command allows elements to be selected and moved to another point on the screen. 

• Click Opus > Move or click on the Move icon  

• Left click on the elements to be moved. 
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• Once all of the required elements have been selected, right click to accept them. 

• The command line will now read Move: Basepoint (Relative), left click on a point on the 

selected elements. 

• Move: To Point will now appear on the command line. This gives the user the chance to move 

the selected elements by entering a set of co-ordinates or by left clicking on a specific 

location. 

• The command line will now read Offset: Offset. Enter a set of co-ordinates to move the 

selected elements to their final location. 

 

Copy 

The Copy command allows the user to duplicate selected elements, saving the need to repeat 

drawing work that has already been done. This works in a very similar way to the Move option. 

 

• In Opus, draw a Square.  

• Click Opus > Copy or select the Copy icon   

• Left click on each of the elements to be copied, in this case all four sides of the square.  

• When all the elements are selected, right click.  

• The command line will now read Copy: Base Point (Relative) Copying using a base point can 

save time. In this example, one of the corners of the square can be used. Click the bottom 

left-hand corner in the larger square as the base point.  

• The selected elements and the basepoint will be attached to the cursor. The command line 

now reads Copy: To Point, this time click on the position you wish to copy it to.  

• The command line will now read Offset: Offset, in this case leave this at 0,0 and the selected 

elements will have been copied into the position selected while retaining the original square. 

 

 

Rotate  

The Rotate command allows selected elements to be rotated from a specific point and by a specified 

angle. 

 

• Click Opus > Rotate or click on the Rotate icon   

• The command line will now read Rotate: Select Elements,  left click on all of the elements to 

be rotated, then right click to complete the selection.  

• At the Rotate: About Point (Relative) prompt, left click on the point from which the selected 

elements will be rotated.  

• The command line now reads Rotate: By (-=cw degs), enter the amount of degrees to rotate 

the selected elements by. 

 

 

 

 

Align 

The Align command allows two sets of elements to be merged by selecting a group of elements and 

specifying where two points of that group of elements should be moved. 

 

The easiest way to illustrate this would be to follow the example below. 

 

• Within Opus, draw two right angled triangles with a base length and height of 300mm, as in 

the example below. It is now possible to Align these triangles to create a 300mm x 300mm 

square.  
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• Click Opus > Align to enable the Align option.  

• The command line will read Align: Select Elements, left click on all three of the lines in the 

triangle on the left and right click to complete the selection.  

• The command line changes to Align: Source 1 (Relative), click on the point at the top left of 

the right hand triangle.  

• At the Align: Destination 1 (Relative), click on the point at the bottom right of the left hand 

triangle.  

• The command line changes to Align: Source 2 (Relative), click on the point at the bottom 

right of the right hand triangle.  

• At the Align: Destination 2 (Relative), click on the point at the top left of the left hand 

triangle.  

• These settings will now align Source 1 to Destination 1 and Source 2 to Destination 2, 

resulting in the following square. 

 

 
 

 

 

Mirror 

The Mirror command allows a number of elements to be selected and flipped over. The user has the 

option to copy these elements whilst mirroring or not. 

 

• Click Opus > Mirror or select the Mirror icon   

• Left click once on each of the elements to be mirrored. Then right click to complete the 

selection.  

• The command line will now read Mirror : First Point (y), click on the first point which forms 

the 'mirror' line.  
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• The command line will now change to Mirror : Second Point (y), click on the second point 

which forms the 'mirror' line.  

• The user is now given a choice at the command line, Mirror : Copy: Yes(y), No(n) will 

appear. If y is entered the part will be mirrored and copied, whereas, if n is entered the 

elements will just be mirrored. 

 

Edit 

Edit incorporated the following commands: 

- Fillet  

The Fillet option can be used in three different ways. The two options available from the Opus menu 

are Fillet - End Point and Fillet - Extend. The third option is available from the Fillet icon on the 

Opus toolbar. These are explained below. 

 

Fillet - End Point 

This option allows the user to fillet, or radius a corner where the two lines of the junction actually 

meet. 

 

• Click Opus > Edit > End Point  

• The command line will now read Fillet : Junction (pt)(Relative) This is asking the user to 

select all of the junctions to be filleted.  

• Left click on each junction and right click when the selection is complete.  

• Note: If different radii are required on different junctions it is necessary to perform this 

operation separately for each of the different radii. 

• Fillet : Radius will now appear at the command line. Type the radius for the fillet and press 

Enter  

• The selected junctions will now be filleted at the radius entered.  

 

Fillet - Extend 

This option is similar to the Fillet - End Point described above, apart from the fact that the junction 

doesn't actually meet at a point. This option will draw in a fillet and complete the junction. 

 

• Draw an open corner, where the two lines do not meet.  

• Click Opus > Edit > Fillet > Extend  

• Fillet : Radius will now appear at the command line. Type the radius for the fillet and press 

Enter  

• The command line will now read Fillet : First Element, left click on any of the two lines.  

• The command line will now read Fillet : Second Element, left click on the other line.  

• The radius will be drawn in to reflect the radius amount entered.  

 

The Fillet icon  

Using the fillet icon on the Opus toolbar offers the user a third option when filleting corners. 

 

• Click on the Fillet icon   

• Fillet : Radius will now appear at the command line. Type the radius for the fillet and press 

Enter  

• The command line will now read Fillet: First Element, left click on any one of the two lines 

which form the junction to be filleted.  

• The command line will now read Fillet: Second Element, left click on the other line in the 

junction.  

 

 

- Chamfer 

This command offers the user the opportunity to chamfer, or mitre the corner of a development. 

 

• Click Opus > Edit > Chamfer or select the Chamfer icon   

• The command line now asks, Chamfer: Distance Along First Line enter a distance.  

• Enter a distance at the command line prompt Chamfer : Distance Along Second Line  

• The command line now asks, Chamfer: Trim/No Trim. Type t to mitre and trim the corner or 

n to draw the mitre in and leave the original corner.  
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• The Chamfer: First Element and Chamfer: Second Element options allow the user to select 

the elements which form the junction to be chamfered.  

• When the junction has been selected the chamfer will be drawn in. 

 

-Trim, Extend & Break  

The Trim, Extend and Break commands are very useful drawing tools within Opus and are described 

below. 

 

Trim 

The Trim command allows elements to be shortened by defining bounding elements and using them 

to trim back to. See the example below. 

 

• Click Opus > Edit > Trim or click on the Trim icon   

• The command line will display Trim: Bounding Elements. Left click on every element that is 

to define a boundary; the trimmed elements will be cut back this point. Right-click to 

complete the selection.  

 

 
 

 

 

• The command line will now display Trim: Select Elements. Left Click on the elements that are 

to be trimmed and they will be trimmed back to the selected bounding elements selected 

earlier.  

 

 

 

 

 

Extend 

Although the Extend option does the opposite to the trim option, it is used in virtually the same 

way. It allows an element or elements to be extended up to a defined boundary. 

 

• Click Opus > Edit > Extend or select the Extend icon   

• The command line will display Extend: Bounding Elements. Left click on the elements to be 

used as bounding elements. Right-click to end the selection.  

Bounding Element 

Element to be trimmed 
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• The command line will now display Extend: Select Element (Relative). Left Click on the 

elements to be extended.  

• The selected elements will be extended to the bounding elements selected earlier.  

 

Break 

The Break option is particularly useful when working with circles. It performs an operation similar to 

trim between two defined points. 

 

• Click Opus > Edit > Break or select the Break icon   

• The command line will now display Break: Select Element, left click the element to be 

broken.  

• The command line will now display Break: First Point (Relative), left click on the first point to 

be used for the break.  

• Break: Second Point (Relative), will now be visible at the command line, left click on the 

second point to be used for the break.  

• The line will now be broken to as instructed.  

 

Note: The Break command always breaks the element anticlockwise between the first and second 

points. 

 

-Offset 

The Offset command allows selected elements to be copied and offset by a specified distance.  

 

• In Opus draw a circle.  

• Click Opus > Offset or select the Offset icon   

• The command line will read Offset: Distance or Through Point? Enter an offset value.  

• Offset: Select Element will now appear on the command line. Left click on the element that is 

to be used as the base for the offset. In this case the circle.  

• At the Offset: Select Side prompt, click the side where the element(s) are to be offset to. In 

this case, on the outside of the circle. 

• The new offset line will be drawn in.  

• Once complete, press Esc to exit the offset command. 

 

-Array   

The Array command can be used to quickly re-produce features, for instance as a series of holes or 

access doors. Arrays can be either rectangular or polar. 

 

Rectangular Arrays 

A rectangular array consists of columns (running vertically) and rows (running horizontally). The 

example below has 3 rows and 4 columns of circular holes. 
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To create a Rectangular Array: 

 

• Create one item of the array as a base for the rest of the elements, using any of the drawing 

tools at your disposal. If the example above is being re-created, draw the circle at the 

bottom left.  

• Click Opus > Array or click on the Array icon   

• The command line will now read, Array : Select Elements, left click on the element(s) to be 

arrayed. Right click to complete the selection.  

• The command line will now read, Array : Rectangular (r) or Polar (p), type r and press Enter  

• Array : Number of Columns will now appear at the command line, type in the amount of 

columns required and press Enter  

• The command line will now read, Array : Number of Rows, type in the amount of rows 

required and press Enter  

• The command line will now read, Array : Distance Between Columns. If the selected 

elements are to be arrayed to the left, enter a negative figure, i.e. -100, otherwise a positive 

figure will array the columns to the right. Type a figure as required and press Enter  

• Array : Distance Between Rows will now appear at the command line. If the selected 

elements are to be arrayed downwards, enter a negative figure, i.e. -100, otherwise a 

positive figure will array the rows upwards. Type a figure as required and press Enter  

• The selected elements will now be arrayed according to the figures entered.  

 

Polar Arrays 

A Polar Array is constructed from a selected point with a fixing radius to determine placement, as in 

the following: 

 

 
 

To create a Polar array: 

 

• Create one item of the array as a base for the rest of the elements, using any of the drawing 

tools at your disposal. If the example above is being re-created, draw the circle at the top.  

• Click Opus > Array or click on the Array icon   

• The command line will now read, Array : Select Elements, left click on the element(s) to be 

arrayed. Right click to complete the selection.  

• The command line will now read, Array : Rectangular (r) or Polar (p), type p and press Enter  

• Array : Base Point (Relative) will now appear at the command line, click in the centre of the 

hole at the top.  
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• The command line will now read, Array : Centre Point, click on the centre point of the main 

circle. This will be used as the point at which that the array radius will be drawn from.  

• The command line will now read, Array : Number of Items, enter the amount of items to be 

created in the array, including the one being used as the source for the array, in this case 

the small hole at the top.  

• At the Array : Angle to Fill prompt, enter an angle that the array will cover. By default this is 

360O. Lowering this angle will result in the placement of the array members starting 

anticlockwise from the base member of the array. Enter an Angle and press Enter  

• The command line will now read, Array : Rotate as Copied (y/n). This determines whether 

selected elements are rotated as they are created, so that the same part of each array 

member will make the same angle with the centre. This is of no consequence to circles, but 

will be for other shapes (squares, rectangles etc.). Type y or n as appropriate. 

 

Delete  

The Delete Command allows the user to delete single or multiple selected Elements.  This can also 

be carried out by using the Delete Icon or CTRL+ Delete on the keyboard. 
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Appendix B: Installed Machines 

 

Aim 

 

To look at the setup and configuration of the Cutting Machine and how the software can control 

certain functions and reduce operator error. 

 

Details 

 

The Installed Machines dialogue is where you set up the machines that will write NC data for the 

jobs created in PM2000. To access and amend this dialogue Click on File > Setup > Installed 

Machines or select the Installed Machines icon from the Utility Bar. 

 

 
 

To amend an existing machine click on the Setup button or double click the name of the machine. 

To setup and amend the Tools fitted to the machine click the Tools button.  

To install a new machine click on the New button. 

To delete an installed Machine, click on the machine name, as in the picture above, and click the 

Delete button. 

The Check button is used to check the material / tool settings of the machine, and will display a 

dialogue box of any settings that have not yet been configured, as shown next. 

 
 

The Print button will print out a complete list of settings configured within the 6 tabs of the Machine 

Editor Dialogue and the Installed Machines dialogue. 
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Amending an existing machine or creating a new machine will bring up the Machine Editor dialogue 

box as shown below. There are 6 sections in this dialogue, each of which are attainable through 

their own tab and will be covered in their own section elsewhere within this tutorial.  

 

 
 

Name 

The name of the machine can be changed here. Each machine will have a folder assigned to it. The 

folder contains various files applicable to that machine and the tools it uses. The folder name is the 

same as the machine name and exists in the database folder in the installation directory. For 

example the machine name "Burny" settings will be placed in the "C:\CAM\DATABASE\Burny" folder. 

If the machine name is changed, the folder name is also changed. 

 

Dimensions 

Units are in mm or inches. 

 

Rail Axis 

The maximum length over which the tools can operate along the long machine axis. 

 

Beam Axis 

The maximum length over which the tools can operate along the short machine axis. 

 

Preset Points 

The diagram of the Machine has a button in each corner. These are used to determine four key 

reference points. Reference points rotate the X and Y axis; they are never reversed. . 
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Select a reference point and then click on the required corner. 

 

Origin 

Set to define the machine's x/y axis orientation and, in most cases the x=0, y=0 point. This is 

machine/controller dependent and after installation should not be altered unless instructed by the 

software vendor. If the 0, 0 point does not coincide with this convention, choose the axis convention 

here and then enter a machine zero offset in the controller section. 

 

Home Point 

The position where the machine will return to when home is selected on the controller. 

 

Start Point 

The machine will start to cut a nest from this point. If this is not the same as the home point, the 

tool will make a rapid traverse to the corner of the nest determined by the start point. 

 

Park Point 

The position the tool will return to after the parts are cut, provided that the 'Go to Park Point' tick 

box is ticked. 

 

Block Point 

The Block Point is used in Level 1 Installations where NC is written for a single part in Profiler.  The 

Block Point is a single point on the bounding rectangle of the part, the last line of NC would be a 

command to move back to the Block Point so the same part could be cut again. 

 

Nesting 

Allows the user to specify a Nesting position on the plate different from the Home position. 

 
Traverse Rate 

Enter the speed at which the tool head will move when in rapid traverse - typically 20,000 

mm/minute or 800"/minute, but check with your machine supplier. This value is used to accurately 

calculate the time to cut a sheet of parts. 

 

 
 

Dual Tables 

Some machines can have two cutting tables or are long enough to allow two sheets to be mounted 

along the length. The software can be set up to move between tables automatically. 

 

Alternate between Tables 

 

 
 



CAM-Duct Training Manual - 2008 

Version 1.00.01 Page 160 of 166 

 

Tick if you wish to automatically move between both table home positions. Click Setup to display: 

 

 
 

Table Separation 

Sets the sheet home point separation distance. 

 

Park Point 

Specifies whether the cutting head is parked at the local machine park point, or midway between 

the dual tables. 

 

Rip Cut 

Before or after cutting a nest, the program can rip cut any remaining length or width of the sheet 

dependent on the settings here. A rip cut is a latitudinal or longitudinal cut that separates unused 

sheet from the part of the sheet that has been cut upon. 

 

 
 

If the rip cut is selected there are different ways it can be implemented. 

 

Along Rail Axis 

Cuts the sheet along the rail length. 

 

Along Beam Axis 

Cuts the sheet along the beam axis. 

 

To specify the type of cut (rail or beam) and the various options, once the appropriate rip cut box is 

ticked click on Setup.  This opens up a new window which enables the following options. 
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Position 

Allows the rip cut to be set either above nest or below nest. 

 

Cut Order 

Allows the rip cut to be set either before nest or after nest. 

 

Follow part boundaries 

Sets the rip cut to follow the outside of the parts on the nest allowing for the margin between 

nested parts.  The screen-shot below shows how the rip cut follows the part boundaries along the 

rail axis. 

 

 
 

 

The Web Cut tab is used to define the criteria for web cutting the material that remains on the sheet 

after the profiled parts have been cut out, on order to make the scrap more manageable. It is 

usually used with oxyfuel cutters as opposed to plasma cutters. 

 

 

Special Features 

Controller and special features settings determine low level machine operations that should not be 

changed without seeking the advice of the software vendor.  To set up or amend these settings, 

• Click on File > Setup > Installed Machines, or select the Installed Machines icon from the 

Utility Bar. 

• Select the machine you wish to amend and double click it. 

• Select the Special Features tab. 
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Remarks 

Remark gives the option to insert text data at the start of the NC code for ease of reading. Most 

controllers allow remarks to be included between remark start and end codes. To access and amend 

this feature, 

• Click on File > Setup > Installed Machines or select the Installed Machines icon from the 

Utility Bar. 

• Select the machine you wish to change or click the new button to add a new one. 

• Double click it or click on the setup button.   

• Select the Remark tab. 
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Suppress Remarks 

If ticked, all remarks will be removed. 

 

Options / Use 

Any comments listed in the right hand column will be included. To add a remark, click on the 

comment in the Left hand column and click the arrow pointing to the right.  The Concatenate button 

will collect all the remarks into a single statement. 

 

Tools 

The tools associated with a machine can be customised to take account of specific requirements of 

individual controllers. To access the dialogue Click on File > Setup > Installed Machines or select the 

Installed Machines icon from the Utility Bar. The Installed Machines dialogue box will be displayed. 
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Normally, only one machine controller will be shown, and it will be highlighted in blue with a green 

dot alongside to indicate that it is the default machine. In cases where there are multiple 

controllers, only one of them will have the green default setting. Click Tools. The Edit Tools for 

Machine dialogue box will be displayed  

 

 
 

Highlight a tool e.g. Air Plasma in this instance, and click Setup. If there are no tools assigned, click 

on Add Tool and choose a relevant tool from the drop-down list, as shown below  

 

 
 

After clicking on Setup for the tool, the Tool details for Machine dialogue box will be displayed.  
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This screen details the specific tool settings for all combinations of material and gauge that exist on 

your database. Some of the settings apply globally (e.g. Pierce Size) whereas others differ with each 

material and gauge (e.g. Feed Rate). More parameters can be added to the list if required for the 

controller and tool, by clicking the Add button and clicking the down arrow to see a list of valid 

parameters:  

 

 
 

Then, for the chosen parameter, you have the option to apply it globally or at a detailed material / 

gauge level 

 

 
 

To edit any of the global parameters, click in the field and change the value: 
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Every Machine will have its own set of parameters that can be configured, some are more expansive 

than others.  I have listed below a few of the more commonly used ones.  If in doubt about any of 

the parameters in your own Install, then contact your supplier before attempting to change any of 

the settings in the Database. 

 

Pierce Size 

This refers to a hole diameter. The cutting machine will pierce any hole that has a diameter less 

than or equal to the entered value. 

 

Arc Slow Min 

The % value is the minimum percentage that the machine will slow to when it comes to a radius 

less than or equal to the value in the Arc Slow Radius field. The machine will not drop to this 

minimum percentage speed instantly, and the drop is proportional to the size of the element. 

To alter any of the material detail entries, double-click anywhere on the row that you wish to 

change. The Details dialogue box will be displayed: 

 

Feed Rate 

This value is in mm per minute for this material and gauge. On some controllers, the feed rate is 

defined within the controller and this value is treated as information only. If the Suppress Feed Rate 

option is chosen, either globally or at this detail level, the feed rates will not be written away to the 

NC data. 

 

Pierce Delay 

This is the time in seconds that it will take for the cutting tool to pierce a hole at this combination of 

material and gauge - i.e. the time that the torch will be stationary while the hole is cut. 

 

Kerf Value 

This caters for the thickness of the cutting tool. The value entered here is the width of material that 

will be removed by the cutting tool (from the Old English coerf - groove). Kerfing will be defined for 

the tool as to the left or the right, and works in conjunction with the cut side - refer to the tool use 

topic for more information. 


